Read the docs
TI-2026-29022 Aliases CVE-2026-40211GHSA-8mqg-g8g6-fvw6

Denial of service via crafted DoH3 queries

Priority LOW 31CWE-770Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-770.

Summary

An attacker can send crafted DNS over HTTP/3 queries, triggering an exception that prevents some buffer from being freed right away. The buffer will be freed at the end of the QUIC connection, but on some setups it might be possible to open enough concurrent DoH3 streams to trigger an out-of-memory condition, resulting in a denial of service.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.007 53rd percentileScored 2026-11-07
Fix Fixed DNSdist (PowerDNS): 1.9.15, 2.0.7

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
PowerDNSDNSdist1.9.0 to before 1.9.15; 2.0.0 to before 2.0.71.9.15, 2.0.7Patch availableCNA
  • DNSdist VendorPowerDNS Affected 1.9.0 to before 1.9.15; 2.0.0 to before 2.0.7 Fixed in 1.9.15, 2.0.7 Patch available CNA

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:powerdns:dnsdist:*:*:*:*:*:*:*:*——PowerDNS
  • cpe:2.3:a:powerdns:dnsdist:*:*:*:*:*:*:*:* Versions — — ·PowerDNS

Remediation

  • Fix · CNA DNSdist (PowerDNS) Fixed in 1.9.15, 2.0.7

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    PowerDNS DNSdist 1.9.15, 2.0.7

    6 records Highest priority Priority LOW 6 LOW

    Other records, highest priority first

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-40211
  2. 2026-10-03 Alias added: GHSA-8mqg-g8g6-fvw6

References

  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2015-01678 The label decompression functionality in PowerDNS Recursor 3.5.x, 3.6.x before 3.6.3, and… CVSS 2.0HIGH 7.8
  • TI-2021-14878 PowerDNS Authoritative Server 4.5.0 before 4.5.1 allows anybody to crash the process by… CVSS 3.1HIGH 7.5
  • TI-2016-04703 PowerDNS (aka pdns) Authoritative Server before 3.4.10 does not properly handle a . CVSS 3.0HIGH 7.5
  • TI-2018-12065 Out-of-bounds read in [UNKNOWN] pdns-recursor CVSS 3.0HIGH 7.5
See all 130 →

Sources