OpenRemote has XXE in Velbus Asset Import
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
OpenRemote is an open-source internet-of-things platform. Prior to version 1.22.0, the Velbus asset import path parses attacker-controlled XML without explicit XXE hardening. An authenticated user who can call the import endpoint may trigger XML external entity processing, which can lead to server-side file disclosure and SSRF. The target file must be less than 1023 characters. Version 1.22.0 fixes the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| openremote | openremote | before 1.22.0 | 1.22.0 | Patch available | CNA |
| — | io.openremote:openremote-manager (Maven) | before 1.22.0 | 1.22.0 | Patch available | GHSA-g24f-mgc3-jwwc |
- openremote Vendoropenremote Affected before 1.22.0 Fixed in 1.22.0 Patch available CNA
- io.openremote:openremote-manager (Maven) Vendor— Affected before 1.22.0 Fixed in 1.22.0 Patch available GHSA-g24f-mgc3-jwwc
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:openremote:openremote:*:*:*:*:*:*:*:* | before 1.22.0 | Vulnerable | openremote |
- cpe:2.3:a:openremote:openremote:*:*:*:*:*:*:*:* Versions before 1.22.0 Vulnerable ·openremote
Remediation
- Fix · CNA openremote (openremote) Fixed in 1.22.0
- Fix · GHSA-g24f-mgc3-jwwc io.openremote:openremote-manager (Maven) Fixed in 1.22.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-40882
- 2026-10-03 Alias added: GHSA-g24f-mgc3-jwwc
References
More Openremote vulnerabilities
- TI-2022-13714 An issue was discovered in OpenRemote through 1.0.4 allows attackers to execute arbitrary… CVSS 3.1CRITICAL 9.8
- TI-2026-28724 OpenRemote is Vulnerable to Expression Injection CVSS 3.1CRITICAL 10.0
- TI-2026-29790 OpenRemote has Improper Access Control via updateUserRealmRoles function CVSS 3.1HIGH 7.0
- TI-2026-44461 OpenRemote < 1.26.0 SQL Injection via Crosstab Export CVSS 4.0HIGH 7.2
Sources
- CVE-2026-40882 · CVE Program
- CVE-2026-40882 · NVD
- FIRST EPSS
- GHSA-g24f-mgc3-jwwc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences