OpenRemote has Improper Access Control via updateUserRealmRoles function
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · High · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
OpenRemote is an open-source internet-of-things platform. Prior to version 1.22.1, a user who has `write:admin` in one Keycloak realm can call the Manager API to update Keycloak realm roles for users in another realm, including `master`. The handler uses the `{realm}` path segment when talking to the identity provider but does not check that the caller may administer that realm. This could result in a privilege escalation to `master` realm administrator if the attacker controls any user in `master` realm. Version 1.22.1 fixes the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| openremote | openremote | before 1.22.1 | 1.22.1 | Patch available | CNA |
| — | io.openremote:openremote-manager (Maven) | before 1.22.1 | 1.22.1 | Patch available | GHSA-49vv-25qx-mg44 |
- openremote Vendoropenremote Affected before 1.22.1 Fixed in 1.22.1 Patch available CNA
- io.openremote:openremote-manager (Maven) Vendor— Affected before 1.22.1 Fixed in 1.22.1 Patch available GHSA-49vv-25qx-mg44
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:openremote:openremote:*:*:*:*:*:*:*:* | before 1.22.1 | Vulnerable | openremote |
- cpe:2.3:a:openremote:openremote:*:*:*:*:*:*:*:* Versions before 1.22.1 Vulnerable ·openremote
Remediation
- Fix · CNA openremote (openremote) Fixed in 1.22.1
- Fix · GHSA-49vv-25qx-mg44 io.openremote:openremote-manager (Maven) Fixed in 1.22.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-41166
- 2026-10-03 Alias added: GHSA-49vv-25qx-mg44
References
More Openremote vulnerabilities
- TI-2022-13714 An issue was discovered in OpenRemote through 1.0.4 allows attackers to execute arbitrary… CVSS 3.1CRITICAL 9.8
- TI-2026-28724 OpenRemote is Vulnerable to Expression Injection CVSS 3.1CRITICAL 10.0
- TI-2026-29538 OpenRemote has XXE in Velbus Asset Import CVSS 3.1HIGH 7.6
- TI-2026-44461 OpenRemote < 1.26.0 SQL Injection via Crosstab Export CVSS 4.0HIGH 7.2
Sources
- CVE-2026-41166 · CVE Program
- CVE-2026-41166 · NVD
- FIRST EPSS
- GHSA-49vv-25qx-mg44 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences