Read the docs

openremote

Records19All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical4CVSS 9.0–10.0
CVSS high9CVSS 7.0–8.9

Exploited now

openremote records in CISA KEV

No openremote vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

19 records

Priority HIGH 74

OpenRemote 1.2.0 before 1.31.0 contains a missing authorization vulnerability in GatewayServiceResource that allows any authenticated user to start, stop and query gateway tunnels without an administrative role.

CVSS 4.0CRITICAL 9.0 Network Low privileges No interaction EPSS 0.0035 Published 2026-10-22 Fixed in 1.31.0 CWE-862
Priority HIGH 70

OpenRemote before 1.25.0 contains an insecure direct object reference (IDOR) vulnerability in the bulk alarm deletion endpoint that allows authenticated users to permanently delete alarms belonging to other tenants by su…

CVSS 4.0HIGH 8.6 Network Low privileges No interaction EPSS 0.00326 Published 2026-06-23 Fixed in 1.25.0 CWE-639
TI-2026-29538 CVE-2026-40882 · GHSA-g24f-mgc3-jwwc

OpenRemote has XXE in Velbus Asset Import

Priority HIGH 66

OpenRemote is an open-source internet-of-things platform.

CVSS 3.1HIGH 7.6 Network Low privileges No interaction EPSS 0.00258 Published 2026-04-22 Fixed in 1.22.0 CWE-611
Priority HIGH 65

OpenRemote before 1.26.0 contain an authenticated SQL injection vulnerability in the datapoint crosstab export endpoint that constructs PostgreSQL queries by concatenating asset display names into raw SQL.

CVSS 4.0HIGH 7.2 Network Low privileges No interaction EPSS 0.00498 Published 2026-07-17 Fixed in 1.26.0 CWE-89
Priority MEDIUM 57

OpenRemote versions before 1.26.2 contain an information disclosure vulnerability in the SyslogResource REST endpoint that fails to filter operational logs by realm.

CVSS 4.0MEDIUM 5.3 Network Low privileges No interaction EPSS 0.00229 Published 2026-07-21 Fixed in 1.26.2 CWE-200
Priority MEDIUM 49

OpenRemote before 1.26.2 contains an authentication bypass vulnerability in the console registration API that allows unauthenticated attackers to update existing console assets by supplying a known asset identifier.

CVSS 4.0CRITICAL 9.3 Network No auth No interaction EPSS 0.00679 Published 2026-07-25 Fixed in 1.26.2 CWE-639
Priority MEDIUM 45

OpenRemote core (openremote-manager) before 1.31.0 does not perform realm or gateway-descendant authorization on inbound edge gateway events and maps event asset IDs only through the reversible GatewayConnector.mapAssetI…

CVSS 4.0LOW 2.3 Network Low privileges No interaction EPSS 0.00205 Published 2026-10-25 Fixed in 1.31.0 CWE-639
Priority LOW 36

OpenRemote versions before 1.28.0 contain a cross-realm information disclosure vulnerability in the Notification REST API that allows per-realm tenant administrators to read all tenants' sent notifications including mess…

CVSS 4.0HIGH 8.3 Network Low privileges No interaction EPSS 0.00392 Published 2026-08-27 Fixed in 1.28.0 CWE-200
Priority LOW 24

OpenRemote (org.openremote:openremote) versions <= 1.26.2 contain an insecure direct object reference vulnerability in the setAssetLinks endpoint of AlarmResourceImpl.

CVSS 4.0MEDIUM 5.3 Network Low privileges No interaction EPSS 0.00239 Published 2026-08-01 Fixed in 1.27.0 CWE-863
Priority LOW 11

OpenRemote before 1.31.0 contains an authorization bypass vulnerability that allows realm admins to impersonate gateways in other realms because GatewayService only checks the gateway ID, not the realm.

CVSS 4.0LOW 2.1 Network High privileges No interaction EPSS 0.0024 Published 2026-10-25 Fixed in 1.31.0 CWE-639
Open these records in search →