Inbound WS-Security allows RSA PKCS#1 v1.5 key transport by default
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-327.
Summary
Wss4jSecurityInterceptor defaulted allowRSA15KeyTransportAlgorithm to true, overriding Apache WSS4J's safer default for validation RequestData. Inbound WS-Security decryption could therefore accept RSA PKCS#1 v1.5 (rsa-1_5) encrypted key material unless operators explicitly reconfigured the flag. Affected versions: Spring Web Services 5.0.0 through 5.0.1; 4.1.0 through 4.1.3; 4.0.0 through 4.0.18; 3.1.0 through 3.1.8.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| VMware | Spring Web Services | 5.0.0 to before 5.0.1.1; 4.1.0 to before 4.1.3.1; 4.0.0 to before 4.0.19; 3.1.0 to before 3.1.9 | 5.0.1.1, 4.1.3.1, 4.0.19, 3.1.9 | Patch available | CNA |
| — | org.springframework.ws:spring-ws-security (Maven) | 5.0.0 to before 5.0.2 | 5.0.2 | Patch available | GHSA-p7qj-2q5w-f9r7 |
| — | org.springframework.ws:spring-ws-security (Maven) | 4.1.0 to before 4.1.4 | 4.1.4 | Patch available | GHSA-p7qj-2q5w-f9r7 |
| — | org.springframework.ws:spring-ws-security (Maven) | 4.0.0 – 4.0.18 | — | No fix listed | GHSA-p7qj-2q5w-f9r7 |
| — | org.springframework.ws:spring-ws-security (Maven) | 3.1.0 – 3.1.8 | — | No fix listed | GHSA-p7qj-2q5w-f9r7 |
- Spring Web Services VendorVMware Affected 5.0.0 to before 5.0.1.1; 4.1.0 to before 4.1.3.1; 4.0.0 to before 4.0.19; 3.1.0 to before 3.1.9 Fixed in 5.0.1.1, 4.1.3.1, 4.0.19, 3.1.9 Patch available CNA
- org.springframework.ws:spring-ws-security (Maven) Vendor— Affected 5.0.0 to before 5.0.2 Fixed in 5.0.2 Patch available GHSA-p7qj-2q5w-f9r7
- org.springframework.ws:spring-ws-security (Maven) Vendor— Affected 4.1.0 to before 4.1.4 Fixed in 4.1.4 Patch available GHSA-p7qj-2q5w-f9r7
- org.springframework.ws:spring-ws-security (Maven) Vendor— Affected 4.0.0 – 4.0.18 Fixed in — No fix listed GHSA-p7qj-2q5w-f9r7
- org.springframework.ws:spring-ws-security (Maven) Vendor— Affected 3.1.0 – 3.1.8 Fixed in — No fix listed GHSA-p7qj-2q5w-f9r7
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:broadcom:spring_web_services:*:*:*:*:*:*:*:* | before 3.1.9; 4.0.0 to before 4.0.19; 4.1.0 to before 4.1.3.1; 5.0.0 to before 5.0.1.1 | Vulnerable | Broadcom |
- cpe:2.3:a:broadcom:spring_web_services:*:*:*:*:*:*:*:* Versions before 3.1.9; 4.0.0 to before 4.0.19; 4.1.0 to before 4.1.3.1; 5.0.0 to before 5.0.1.1 Vulnerable ·Broadcom
Remediation
- Fix · CNA Spring Web Services (Spring) Fixed in 5.0.1.1, 4.1.3.1, 4.0.19, 3.1.9
- Fix · GHSA-p7qj-2q5w-f9r7 org.springframework.ws:spring-ws-security (Maven) Fixed in 5.0.2 Advisory →
- Fix · GHSA-p7qj-2q5w-f9r7 org.springframework.ws:spring-ws-security (Maven) Fixed in 4.1.4 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Spring Web Services 3.1.9, 4.0.19 and 2 more versions
7 records Highest priority Priority MEDIUM 3 MEDIUM, 4 LOW
Other records, highest priority first
- TI-2026-29650 Spring WS SSRF via unvalidated WS-Addressing reply destinationsPriority MEDIUM 43
- TI-2026-29649 Jaxp13 XPath XXE via StreamSource and SAXSourcePriority MEDIUM 42
- TI-2026-29645 Wss4jSecurityInterceptor disables WS-I BSP validation by defaultPriority MEDIUM 41
Timeline
- 2026-10-02 Threatist record created from CVE-2026-40996
- 2026-10-03 Alias added: GHSA-p7qj-2q5w-f9r7
References
More VMware vulnerabilities
- TI-2026-42442 vCenter directory-traversal vulnerability KEVCVSS 3.1CRITICAL 9.8
- TI-2024-26040 Privilege escalation in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
- TI-2024-26039 Heap-overflow in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
- TI-2024-24610 Out-of-bounds write in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
- TI-2023-16914 VMware vCenter Server Out-of-Bounds Write Vulnerability KEVCVSS 3.1CRITICAL 9.8
- TI-2023-07303 Command injection in Aria Operations for Networks KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-40996 · CVE Program
- CVE-2026-40996 · NVD
- FIRST EPSS
- GHSA-p7qj-2q5w-f9r7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences