Unencoded HTML Outputs in Spring Security May Allow Cross-Site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
An attacker able to influence values in RelyingPartyRegistration may be able to run arbitrary code on HTML forms generated by Spring Security filters. Affected versions: Spring Security 5.7.0 through 5.7.23; 5.8.0 through 5.8.25; 6.3.0 through 6.3.16; 6.4.0 through 6.4.16; 6.5.0 through 6.5.10; 7.0.0 through 7.0.5.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| VMware | Spring Security | 5.7.0 to before 5.7.24; 5.8.0 to before 5.8.26; 6.3.0 to before 6.3.17; 6.4.0 to before 6.4.17; 6.5.0 to before 6.5.10.2; 7.0.0 to before 7.0.5.1 | 5.7.24, 5.8.26, 6.3.17, 6.4.17, 6.5.10.2, 7.0.5.1 | Patch available | CNA |
| — | org.springframework.security:spring-security-saml2-service-provider (Maven) | 7.0.0 to before 7.0.6 | 7.0.6 | Patch available | GHSA-3pjj-qpw6-5fcm |
| — | org.springframework.security:spring-security-saml2-service-provider (Maven) | 6.5.0 to before 6.5.11 | 6.5.11 | Patch available | GHSA-3pjj-qpw6-5fcm |
| — | org.springframework.security:spring-security-saml2-service-provider (Maven) | 6.4.0 – 6.4.16 | — | No fix listed | GHSA-3pjj-qpw6-5fcm |
| — | org.springframework.security:spring-security-saml2-service-provider (Maven) | 6.3.0 – 6.3.16 | — | No fix listed | GHSA-3pjj-qpw6-5fcm |
| — | org.springframework.security:spring-security-saml2-service-provider (Maven) | 5.8.0 – 5.8.25 | — | No fix listed | GHSA-3pjj-qpw6-5fcm |
| — | org.springframework.security:spring-security-saml2-service-provider (Maven) | up to 5.7.23 | — | No fix listed | GHSA-3pjj-qpw6-5fcm |
- Spring Security VendorVMware Affected 5.7.0 to before 5.7.24; 5.8.0 to before 5.8.26; 6.3.0 to before 6.3.17; 6.4.0 to before 6.4.17; 6.5.0 to before 6.5.10.2; 7.0.0 to before 7.0.5.1 Fixed in 5.7.24, 5.8.26, 6.3.17, 6.4.17, 6.5.10.2, 7.0.5.1 Patch available CNA
- org.springframework.security:spring-security-saml2-service-provider (Maven) Vendor— Affected 7.0.0 to before 7.0.6 Fixed in 7.0.6 Patch available GHSA-3pjj-qpw6-5fcm
- org.springframework.security:spring-security-saml2-service-provider (Maven) Vendor— Affected 6.5.0 to before 6.5.11 Fixed in 6.5.11 Patch available GHSA-3pjj-qpw6-5fcm
- org.springframework.security:spring-security-saml2-service-provider (Maven) Vendor— Affected 6.4.0 – 6.4.16 Fixed in — No fix listed GHSA-3pjj-qpw6-5fcm
- org.springframework.security:spring-security-saml2-service-provider (Maven) Vendor— Affected 6.3.0 – 6.3.16 Fixed in — No fix listed GHSA-3pjj-qpw6-5fcm
- org.springframework.security:spring-security-saml2-service-provider (Maven) Vendor— Affected 5.8.0 – 5.8.25 Fixed in — No fix listed GHSA-3pjj-qpw6-5fcm
- org.springframework.security:spring-security-saml2-service-provider (Maven) Vendor— Affected up to 5.7.23 Fixed in — No fix listed GHSA-3pjj-qpw6-5fcm
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:vmware:spring_security:*:*:*:*:*:*:*:* | 5.7.0 to before 5.7.24; 5.8.0 to before 5.8.26; 6.3.0 to before 6.3.17; 6.4.0 to before 6.4.17; 6.5.0 to before 6.5.10.2; 7.0.0 to before 7.0.5.1 | Vulnerable | VMware |
- cpe:2.3:a:vmware:spring_security:*:*:*:*:*:*:*:* Versions 5.7.0 to before 5.7.24; 5.8.0 to before 5.8.26; 6.3.0 to before 6.3.17; 6.4.0 to before 6.4.17; 6.5.0 to before 6.5.10.2; 7.0.0 to before 7.0.5.1 Vulnerable ·VMware
Remediation
- Fix · CNA Spring Security (Spring) Fixed in 5.7.24, 5.8.26, 6.3.17, 6.4.17, 6.5.10.2, 7.0.5.1
- Fix · GHSA-3pjj-qpw6-5fcm org.springframework.security:spring-security-saml2-service-provider (Maven) Fixed in 7.0.6 Advisory →
- Fix · GHSA-3pjj-qpw6-5fcm org.springframework.security:spring-security-saml2-service-provider (Maven) Fixed in 6.5.11 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Spring Security 5.7.24, 5.8.26 and 4 more versions
4 records Highest priority Priority LOW 4 LOW
Other records, highest priority first
- TI-2026-29639 Unbounded DEFLATE Inflation in SAML 2.0 Service ProviderPriority LOW 39
- TI-2026-30222 Open Redirect When Using CookieRequestCachePriority LOW 27
- TI-2026-30211 SAML Payloads Decrypted Without Valid SignaturePriority LOW 23
Timeline
- 2026-10-02 Threatist record created from CVE-2026-41003
- 2026-10-03 Alias added: GHSA-3pjj-qpw6-5fcm
References
More VMware Spring Security vulnerabilities
- TI-2023-16900 Improper access control in Spring Security CVSS 3.1CRITICAL 9.8
- TI-2022-13611 Authorization bypass in Spring by VMware CVSS 3.1CRITICAL 9.8
- TI-2022-07154 Incorrect authorization in Spring Security CVSS 3.1CRITICAL 9.8
- TI-2026-42404 Spring Security embedded UnboundID LDAP server exposes well-known administrative bind DN on all network interfaces CVSS 3.1CRITICAL 9.4
- TI-2026-18257 Under Some Conditions Spring Security HTTP Headers Are not Written CVSS 3.1CRITICAL 9.1
- TI-2014-02853 Improper authentication in Pivotal Spring Security CVSS 3.0CRITICAL 9.8
Sources
- CVE-2026-41003 · CVE Program
- CVE-2026-41003 · NVD
- FIRST EPSS
- GHSA-3pjj-qpw6-5fcm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences