Read the docs
TI-2026-30086 Aliases CVE-2026-41500GHSA-wxw2-rwmh-vr8f

electerm has Command Injection Vulnerability via runMac function

Priority MEDIUM 52CWE-77Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-77.

Summary

electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Prior to version 3.3.8, a command injection vulnerability exists in github.com/elcterm/electerm/npm/install.js:150. The runMac() function appends attacker-controlled remote releaseInfo.name directly into an exec("open ...") command without validation. This issue has been patched in version 3.3.8.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01572 75th percentileScored 2026-11-07
Fix Fixed electerm (electerm): 3.3.8electerm (npm): 3.3.8

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
electermelectermbefore 3.3.83.3.8Patch availableCNA
—electerm (npm)before 3.3.83.3.8Patch availableGHSA-wxw2-rwmh-vr8f
  • electerm Vendorelecterm Affected before 3.3.8 Fixed in 3.3.8 Patch available CNA
  • electerm (npm) Vendor— Affected before 3.3.8 Fixed in 3.3.8 Patch available GHSA-wxw2-rwmh-vr8f

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:electerm_project:electerm:*:*:*:*:*:*:*:*before 3.3.8Vulnerableelecterm
  • cpe:2.3:a:electerm_project:electerm:*:*:*:*:*:*:*:* Versions before 3.3.8 Vulnerable ·electerm

Remediation

  • Fix · CNA electerm (electerm) Fixed in 3.3.8
  • Fix · GHSA-wxw2-rwmh-vr8f electerm (npm) Fixed in 3.3.8 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-41500
  2. 2026-10-03 Alias added: GHSA-wxw2-rwmh-vr8f

References

  • TI-2020-14501 An issue was discovered in Electerm 1.3.22, allows attackers to execute arbitrary code… CVSS 3.1CRITICAL 9.8
  • TI-2026-30087 electerm has Command Injection Vulnerability via runLinux function CVSS 3.1CRITICAL 9.8
  • TI-2026-31998 Unvalidated shell.openExternal in electerm allows arbitrary protocol execution via terminal link click CVSS 3.1CRITICAL 9.6
  • TI-2026-32001 electerm: dangerous code can be run through links or command line CVSS 4.0CRITICAL 9.4
  • TI-2026-33147 electerm: Local code through electerm's single-instance socket CVSS 4.0CRITICAL 9.3
  • TI-2026-31997 electerm: Path traversal in electerm runWidget leads to arbitrary code execution CVSS 3.1HIGH 8.4
See all 9 →

Sources