electerm has Command Injection Vulnerability via runLinux function
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-77.
Summary
electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Prior to version 3.3.8, a command injection vulnerability exists in github.com/elcterm/electerm/npm/install.js:130. The runLinux() function appends attacker-controlled remote version strings directly into an exec("rm -rf ...") command without validation. This issue has been patched in version 3.3.8.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| electerm | electerm | before 3.3.8 | 3.3.8 | Patch available | CNA |
| — | electerm (npm) | before 3.3.8 | 3.3.8 | Patch available | GHSA-8x35-hph8-37hq |
- electerm Vendorelecterm Affected before 3.3.8 Fixed in 3.3.8 Patch available CNA
- electerm (npm) Vendor— Affected before 3.3.8 Fixed in 3.3.8 Patch available GHSA-8x35-hph8-37hq
Remediation
- Fix · CNA electerm (electerm) Fixed in 3.3.8
- Fix · GHSA-8x35-hph8-37hq electerm (npm) Fixed in 3.3.8 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-41501
- 2026-10-03 Alias added: GHSA-8x35-hph8-37hq
References
Patch 2
More Electerm vulnerabilities
- TI-2020-14501 An issue was discovered in Electerm 1.3.22, allows attackers to execute arbitrary code… CVSS 3.1CRITICAL 9.8
- TI-2026-30086 electerm has Command Injection Vulnerability via runMac function CVSS 3.1CRITICAL 9.8
- TI-2026-31998 Unvalidated shell.openExternal in electerm allows arbitrary protocol execution via terminal link click CVSS 3.1CRITICAL 9.6
- TI-2026-32001 electerm: dangerous code can be run through links or command line CVSS 4.0CRITICAL 9.4
- TI-2026-33147 electerm: Local code through electerm's single-instance socket CVSS 4.0CRITICAL 9.3
- TI-2026-31997 electerm: Path traversal in electerm runWidget leads to arbitrary code execution CVSS 3.1HIGH 8.4
Sources
- CVE-2026-41501 · CVE Program
- CVE-2026-41501 · NVD
- FIRST EPSS
- GHSA-8x35-hph8-37hq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences