electerm: dangerous code can be run through links or command line
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-829.
Summary
electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. From versions 3.0.6 to before 3.8.15, electerm is vulnerable to arbitrary local code execution via deep links, CLI --opts, or crafted shortcuts. Exploit requires clicking a crafted electerm://... link or opening a crafted shortcut/command that launches electerm with attacker-controlled opts. This issue has been patched in version 3.8.15.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| electerm | electerm | 3.0.6 to before 3.8.15 | 3.8.15 | Patch available | CNA |
| — | electerm (npm) | 3.0.6 to before 3.8.8 | 3.8.8 | Patch available | GHSA-mpm8-cx2p-626q |
- electerm Vendorelecterm Affected 3.0.6 to before 3.8.15 Fixed in 3.8.15 Patch available CNA
- electerm (npm) Vendor— Affected 3.0.6 to before 3.8.8 Fixed in 3.8.8 Patch available GHSA-mpm8-cx2p-626q
Remediation
- Fix · CNA electerm (electerm) Fixed in 3.8.15
- Fix · GHSA-mpm8-cx2p-626q electerm (npm) Fixed in 3.8.8 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-43944
- 2026-10-03 Alias added: GHSA-mpm8-cx2p-626q
- 2026-10-20 EPSS moved to the 50th–90th percentile
- 2026-10-25 EPSS moved to the below the 50th percentile
References
Patch 3
More Electerm vulnerabilities
- TI-2020-14501 An issue was discovered in Electerm 1.3.22, allows attackers to execute arbitrary code… CVSS 3.1CRITICAL 9.8
- TI-2026-30086 electerm has Command Injection Vulnerability via runMac function CVSS 3.1CRITICAL 9.8
- TI-2026-30087 electerm has Command Injection Vulnerability via runLinux function CVSS 3.1CRITICAL 9.8
- TI-2026-31998 Unvalidated shell.openExternal in electerm allows arbitrary protocol execution via terminal link click CVSS 3.1CRITICAL 9.6
- TI-2026-33147 electerm: Local code through electerm's single-instance socket CVSS 4.0CRITICAL 9.3
- TI-2026-31997 electerm: Path traversal in electerm runWidget leads to arbitrary code execution CVSS 3.1HIGH 8.4
Sources
- CVE-2026-43944 · CVE Program
- CVE-2026-43944 · NVD
- FIRST EPSS
- GHSA-mpm8-cx2p-626q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences