Apache Syncope: JexlContextBuilder Information Disclosure
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.
Summary
Exposure of Sensitive Information Through Data Queries vulnerability in Apache Syncope. An administrator with adequate entitlements for Derived Schemas can create a malicious JEXL expression which allows any administrator with sufficient entitlements for User read to access User-related security-sensitive information. This issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0. Users are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by further restricting the JEXL expression definition.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Syncope | 3.0 – 3.0.16; 4.0 – 4.0.5; 4.1 – 4.1.0 | — | No fix listed | CNA |
| — | org.apache.syncope.core:syncope-core-provisioning-api (Maven) | 3.0.0-M0 – 3.0.16 | — | No fix listed | GHSA-vr35-jm2f-8wg2 |
| — | org.apache.syncope.core:syncope-core-provisioning-api (Maven) | 4.0.0-M0 to before 4.0.6 | 4.0.6 | Patch available | GHSA-vr35-jm2f-8wg2 |
| — | org.apache.syncope.core:syncope-core-provisioning-api (Maven) | 4.1.0-M0 to before 4.1.1 | 4.1.1 | Patch available | GHSA-vr35-jm2f-8wg2 |
- Apache Syncope VendorApache Affected 3.0 – 3.0.16; 4.0 – 4.0.5; 4.1 – 4.1.0 Fixed in — No fix listed CNA
- org.apache.syncope.core:syncope-core-provisioning-api (Maven) Vendor— Affected 3.0.0-M0 – 3.0.16 Fixed in — No fix listed GHSA-vr35-jm2f-8wg2
- org.apache.syncope.core:syncope-core-provisioning-api (Maven) Vendor— Affected 4.0.0-M0 to before 4.0.6 Fixed in 4.0.6 Patch available GHSA-vr35-jm2f-8wg2
- org.apache.syncope.core:syncope-core-provisioning-api (Maven) Vendor— Affected 4.1.0-M0 to before 4.1.1 Fixed in 4.1.1 Patch available GHSA-vr35-jm2f-8wg2
Remediation
- Fix · GHSA-vr35-jm2f-8wg2 org.apache.syncope.core:syncope-core-provisioning-api (Maven) Fixed in 4.0.6 Advisory →
- Fix · GHSA-vr35-jm2f-8wg2 org.apache.syncope.core:syncope-core-provisioning-api (Maven) Fixed in 4.1.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-42797
- 2026-10-03 Alias added: GHSA-vr35-jm2f-8wg2
References
More Apache Syncope vulnerabilities
- TI-2025-35632 Apache Syncope: Remote Code Execution by delegated administrators CVSS 3.1HIGH 7.2
- TI-2026-38503 Apache Syncope: Remote Code Execution via Scripted Connector CVSS 3.1CRITICAL 9.8
- TI-2026-45025 Apache Syncope: RCE via Groovy Sandbox bypass CVSS 3.1CRITICAL 9.8
- TI-2026-44406 Apache Syncope: User self-service privilege escalation CVSS 3.1CRITICAL 9.8
- TI-2026-41245 Apache Syncope: SQL injection vulnerability in Audit Events search CVSS 3.1CRITICAL 9.8
- TI-2026-38491 Apache Syncope: Remote Code Execution via Flowable BPMN Groovy ScriptTask CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-42797 · CVE Program
- CVE-2026-42797 · NVD
- FIRST EPSS
- GHSA-vr35-jm2f-8wg2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences