NGINX ngx_http_proxy_v2_module vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Partial Red Hat: 1 fixed, 3 without a fix
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and Red Hat.
Summary
When NGINX Open Source is configured to proxy HTTP/2 traffic by setting proxy_http_version to 2, and also uses proxy_set_body, an attacker may be able to inject frame headers and payload bytes to the upstream peer. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| F5 | NGINX Open Source | 1.29.4 to before 1.30.1 | 1.31.0, 1.30.1 | Patch available | CNA |
- NGINX Open Source VendorF5 Affected 1.29.4 to before 1.30.1 Fixed in 1.31.0, 1.30.1 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:f5:nginx_gateway_fabric:*:*:*:*:*:*:*:* | 1.3.0 – 1.6.2 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_open_source:*:*:*:*:*:*:*:* | 1.29.4 – 1.30.0 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_gateway_fabric:*:*:*:*:*:*:*:* | 2.0.0 – 2.6.0 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_instance_manager:*:*:*:*:*:*:*:* | 2.16.0 – 2.22.0 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_ingress_controller:*:*:*:*:*:*:*:* | 3.5.0 – 3.7.2; 4.0.0 – 4.0.1; 5.0.0 – 5.4.2 | Vulnerable | F5 |
- cpe:2.3:a:f5:nginx_gateway_fabric:*:*:*:*:*:*:*:* Versions 1.3.0 – 1.6.2 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_open_source:*:*:*:*:*:*:*:* Versions 1.29.4 – 1.30.0 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_gateway_fabric:*:*:*:*:*:*:*:* Versions 2.0.0 – 2.6.0 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_instance_manager:*:*:*:*:*:*:*:* Versions 2.16.0 – 2.22.0 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_ingress_controller:*:*:*:*:*:*:*:* Versions 3.5.0 – 3.7.2; 4.0.0 – 4.0.1; 5.0.0 – 5.4.2 Vulnerable ·F5
Remediation
- Fix · CNA NGINX Open Source (F5) Fixed in 1.31.0, 1.30.1
Red Hat 1 advisory
- RHSA-2026:20351 Released 2026-05-23 · Red Hat rating ImportantRed Hat Hardened Images RPMs bug fix and enhancement update
- Red Hat Hardened Images nginx-1.30.2-1.hum1@aarch64, nginx-1.30.2-1.hum1@src, nginx-1.30.2-1.hum1@x86_64 +22
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
F5 NGINX Open Source 1.30.1
6 records Highest priority Priority HIGH 1 HIGH, 5 LOW
Other records, highest priority first
- TI-2026-31136 NGINX ngx_http_rewrite_module vulnerabilityPriority HIGH 78
- TI-2026-31137 NGINX ngx_http_scgi_module and ngx_http_uwsgi_module vulnerabilityPriority LOW 38
- TI-2026-29212 NGINX ngx_quic_module vulnerabilityPriority LOW 37
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 10 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
| Red Hat Hardened Images | Fixed | RHSA-2026:20351 |
Timeline
- 2026-10-02 Threatist record created from CVE-2026-42926
- 2026-10-03 Alias added: GHSA-v43f-895r-chhh
References
More F5 Nginx Gateway Fabric vulnerabilities
- TI-2026-31136 NGINX ngx_http_rewrite_module vulnerability CVSS 4.0CRITICAL 9.2
- TI-2026-30813 NGINX Map directive and Regex matching vulnerability CVSS 4.0CRITICAL 9.2
- TI-2026-08132 NGINX ngx_http_rewrite_module vulnerability CVSS 4.0CRITICAL 9.2
- TI-2026-30812 NGINX Open-Source ngx_http_v3_module vulnerability CVSS 4.0CRITICAL 9.2
- TI-2026-30432 NGINX ngx_http_proxy_v2_module and ngx_http_grpc_module vulnerability CVSS 4.0CRITICAL 9.2
- TI-2026-42786 NGINX ngx_http_slice_module vulnerability CVSS 4.0HIGH 8.8
Sources
- CVE-2026-42926 · CVE Program
- CVE-2026-42926 · NVD
- FIRST EPSS
- GHSA-v43f-895r-chhh · GitHub Advisory Database · CC BY 4.0
- CVE-2026-42926 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences