phpMyFAQ - Insufficient Authorization Check in Admin API Endpoints
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
phpMyFAQ before 4.1.2 contains an insufficient authorization vulnerability in admin-api routes that allows authenticated ordinary users to access administrative endpoints by only checking login status instead of verifying backend privileges. Attackers with valid frontend user accounts can access sensitive backend operational information including dashboard versions, LDAP configuration, Elasticsearch statistics, and health-check data.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| thorsten | phpmyfaq | 4.1.1 to before 4.1.2 | 4.1.2 | Patch available | CNA |
| — | thorsten/phpmyfaq (Packagist) | 4.1.1 to before 4.1.2 | 4.1.2 | Patch available | GHSA-jrc5-w569-h7h5 |
| — | phpmyfaq/phpmyfaq (Packagist) | 4.1.1 to before 4.1.2 | 4.1.2 | Patch available | GHSA-jrc5-w569-h7h5 |
- phpmyfaq Vendorthorsten Affected 4.1.1 to before 4.1.2 Fixed in 4.1.2 Patch available CNA
- thorsten/phpmyfaq (Packagist) Vendor— Affected 4.1.1 to before 4.1.2 Fixed in 4.1.2 Patch available GHSA-jrc5-w569-h7h5
- phpmyfaq/phpmyfaq (Packagist) Vendor— Affected 4.1.1 to before 4.1.2 Fixed in 4.1.2 Patch available GHSA-jrc5-w569-h7h5
Remediation
- Fix · CNA phpmyfaq (thorsten) Fixed in 4.1.2
- Fix · GHSA-jrc5-w569-h7h5 thorsten/phpmyfaq (Packagist) Fixed in 4.1.2 Advisory →
- Fix · GHSA-jrc5-w569-h7h5 phpmyfaq/phpmyfaq (Packagist) Fixed in 4.1.2 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
thorsten phpmyfaq 4.1.2
13 records Highest priority Priority HIGH 5 HIGH, 8 MEDIUM
Other records, highest priority first
- TI-2026-32868 phpMyFAQ - Unauthenticated Two-Factor Authentication Brute-Force via /admin/check EndpointPriority HIGH 81
- TI-2026-34083 phpMyFAQ - Unauthenticated Information Disclosure via getIdFromSolutionId Permission BypassPriority HIGH 77
- TI-2026-34084 phpMyFAQ - Stored XSS via Utils::parseUrl() in Comment RenderingPriority HIGH 69
Timeline
- 2026-10-02 Threatist record created from CVE-2026-45009
- 2026-10-03 Alias added: GHSA-jrc5-w569-h7h5
References
More thorsten vulnerabilities
- TI-2023-00296 Improper Authentication in thorsten/phpmyfaq CVSS 3.1CRITICAL 9.8
- TI-2026-76118 Authentication bypass in phpMyFAQ via WebAuthn credential injection CVSS 4.0CRITICAL 9.3
- TI-2026-32868 phpMyFAQ - Unauthenticated Two-Factor Authentication Brute-Force via /admin/check Endpoint CVSS 4.0CRITICAL 9.3
- TI-2026-76108 Unauthenticated denial of service in phpMyFAQ API pagination CVSS 4.0HIGH 8.7
- TI-2026-53313 phpMyFAQ 3.1.0 through 4.1.6 Authentication Bypass via LDAP CVSS 4.0HIGH 8.8
- TI-2026-34083 phpMyFAQ - Unauthenticated Information Disclosure via getIdFromSolutionId Permission Bypass CVSS 4.0HIGH 8.7
Sources
- CVE-2026-45009 · CVE Program
- CVE-2026-45009 · NVD
- FIRST EPSS
- GHSA-jrc5-w569-h7h5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences