Read the docs
TI-2026-32986 Aliases CVE-2026-45158

OPNsense: Command Injection via Attacker-Controlled DHCP Config

Priority MEDIUM 42CWE-88Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-88.

Summary

OPNsense is a FreeBSD based firewall and routing platform. Prior to 26.1.8, unsanitized user input is passed to the DHCP configuration of the configured interface, which is processed by a shell script, allowing remote code execution as root on the underlying operating system. This vulnerability is fixed in 26.1.8.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00531 45th percentileScored 2026-11-07
Fix Fixed core (opnsense): 26.1.8

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
opnsensecorebefore 26.1.826.1.8Patch availableCNA
  • core Vendoropnsense Affected before 26.1.8 Fixed in 26.1.8 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:opnsense:opnsense:*:*:*:*:*:*:*:*before 26.1.8Vulnerableopnsense
  • cpe:2.3:a:opnsense:opnsense:*:*:*:*:*:*:*:* Versions before 26.1.8 Vulnerable ·opnsense

Remediation

  • Fix · CNA core (opnsense) Fixed in 26.1.8

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-45158
  2. 2026-10-25 EPSS moved to the below the 50th percentile

References

  • TI-2023-20247 A command injection vulnerability in the component /api/cron/settings/setJob/ of OPNsense… CVSS 3.1CRITICAL 9.8
  • TI-2023-20243 Insecure permissions in the configuration directory (/conf/) of OPNsense Community… CVSS 3.1CRITICAL 9.8
  • TI-2023-20240 A command injection vulnerability in the component diag_backup.php of OPNsense Community… CVSS 3.1CRITICAL 9.8
  • TI-2023-11947 DECISO OPNsense 23.1 does not impose rate limits for authentication, allowing attackers… CVSS 3.1CRITICAL 9.8
  • TI-2023-20246 /ui/cron/item/open in the Cron component of OPNsense Community Edition before 23.7 and… CVSS 3.1CRITICAL 9.6
  • TI-2026-26826 OPNsense has an LDAP Injection via Unsanitized Username in Authentication CVSS 3.1HIGH 8.2
See all 35 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences