Shopware: Privilege Escalation via Sync API Integration Admin Flag Bypass
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-862.
Summary
Shopware is an open commerce platform. Prior to 6.6.10.18 and 6.7.10.1, a non-admin API user with integration:create ACL privilege can escalate to full administrator by creating an integration with admin: true through the Sync API POST /api/_action/sync; the regular integration endpoint POST /api/integration blocks this, but SyncController::sync() routes writes through SyncService to EntityWriter::upsert(), and src/Core/Framework/Integration/IntegrationDefinition.php lacks WriteProtection on the admin field. This issue is fixed in versions 6.6.10.18 and 6.7.10.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| shopware | shopware | before 6.6.10.18; 6.7.0.0 to before 6.7.10.1 | 6.6.10.18, 6.7.10.1 | Patch available | CNA |
| shopware | platform | before 6.6.10.18; 6.7.0.0 to before 6.7.10.1 | 6.6.10.18, 6.7.10.1 | Patch available | CNA |
| — | shopware/platform (Packagist) | 6.7.0.0 to before 6.7.10.1 | 6.7.10.1 | Patch available | GHSA-gv8p-48fr-4fxg |
| — | shopware/platform (Packagist) | before 6.6.10.18 | 6.6.10.18 | Patch available | GHSA-gv8p-48fr-4fxg |
| — | shopware/core (Packagist) | 6.7.0.0 to before 6.7.10.1 | 6.7.10.1 | Patch available | GHSA-gv8p-48fr-4fxg |
| — | shopware/core (Packagist) | before 6.6.10.18 | 6.6.10.18 | Patch available | GHSA-gv8p-48fr-4fxg |
- shopware Vendorshopware Affected before 6.6.10.18; 6.7.0.0 to before 6.7.10.1 Fixed in 6.6.10.18, 6.7.10.1 Patch available CNA
- platform Vendorshopware Affected before 6.6.10.18; 6.7.0.0 to before 6.7.10.1 Fixed in 6.6.10.18, 6.7.10.1 Patch available CNA
- shopware/platform (Packagist) Vendor— Affected 6.7.0.0 to before 6.7.10.1 Fixed in 6.7.10.1 Patch available GHSA-gv8p-48fr-4fxg
- shopware/platform (Packagist) Vendor— Affected before 6.6.10.18 Fixed in 6.6.10.18 Patch available GHSA-gv8p-48fr-4fxg
- shopware/core (Packagist) Vendor— Affected 6.7.0.0 to before 6.7.10.1 Fixed in 6.7.10.1 Patch available GHSA-gv8p-48fr-4fxg
- shopware/core (Packagist) Vendor— Affected before 6.6.10.18 Fixed in 6.6.10.18 Patch available GHSA-gv8p-48fr-4fxg
Remediation
- Fix · CNA shopware (shopware) Fixed in 6.6.10.18, 6.7.10.1
- Fix · CNA platform (shopware) Fixed in 6.6.10.18, 6.7.10.1
- Fix · GHSA-gv8p-48fr-4fxg shopware/platform (Packagist) Fixed in 6.7.10.1 Advisory →
- Fix · GHSA-gv8p-48fr-4fxg shopware/platform (Packagist) Fixed in 6.6.10.18 Advisory →
- Fix · GHSA-gv8p-48fr-4fxg shopware/core (Packagist) Fixed in 6.7.10.1 Advisory →
- Fix · GHSA-gv8p-48fr-4fxg shopware/core (Packagist) Fixed in 6.6.10.18 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-48008
- 2026-10-03 Alias added: GHSA-gv8p-48fr-4fxg
References
Other 6
- https://github.com/shopware/shopware/security/advisories/GHSA-gv8p-48fr-4fxg
- https://github.com/shopware/shopware/commit/1e047f6d7fd9129271e28c1c9f1c272983c6f48f
- https://github.com/shopware/shopware/commit/db5adff33ec30b648979cd1938c87f164f7b3073
- https://github.com/shopware/shopware/releases/tag/v6.6.10.18
- https://github.com/shopware/shopware/releases/tag/v6.7.10.1
- https://github.com/shopware/shopware
More shopware vulnerabilities
- TI-2023-01895 Improper Control of Generation of Code in Twig Rendered Views in Shopware CVSS 3.1HIGH 8.8
- TI-2025-20623 Shopware prior to version 6.5.8.13 is affected by a SQL injection vulnerability in the… CVSS 3.1MEDIUM 6.8
- TI-2024-28343 Shopware vulnerable to Server Side Template Injection in Twig using Context functions CVSS 3.1HIGH 8.3
- TI-2019-09582 In createInstanceFromNamedArguments in Shopware through 5.6.x, a crafted web request can… CVSS 3.1HIGH 8.8
- TI-2016-02607 The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code. CVSS 3.0CRITICAL 9.8
- TI-2025-32365 A stored cross-site scripting (XSS) vulnerability exists in the Shopware 6 installation… CVSS 3.1MEDIUM 6.1
Sources
- CVE-2026-48008 · CVE Program
- CVE-2026-48008 · NVD
- FIRST EPSS
- GHSA-gv8p-48fr-4fxg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences