secure_headers: CSP directive injection via sandbox, plugin_types, and report_to when given untrusted input
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
secure_headers manages application of security headers with many safe defaults. Prior to 7.3.0, secure_headers builds the Content-Security-Policy value by stitching directives with ; separators, and build_sandbox_list_directive, build_media_type_list_directive, and build_report_to_directive interpolate caller-supplied strings without scrubbing ;, \r, or \n. When untrusted input reaches SecureHeaders.override_content_security_policy_directives or append APIs for :sandbox, :plugin_types, or :report_to, an attacker can inject a CSP directive such as script-src 'unsafe-inline' * before the legitimate script-src, enabling XSS reachability through these sinks or CSP report exfiltration. This issue is fixed in version 7.3.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitHub | secure_headers | before 7.3.0 | 7.3.0 | Patch available | CNA |
| — | secure_headers (RubyGems) | before 7.3.0 | 7.3.0 | Patch available | GHSA-rqq5-2gf9-4w4q |
- secure_headers VendorGitHub Affected before 7.3.0 Fixed in 7.3.0 Patch available CNA
- secure_headers (RubyGems) Vendor— Affected before 7.3.0 Fixed in 7.3.0 Patch available GHSA-rqq5-2gf9-4w4q
Remediation
- Fix · CNA secure_headers (github) Fixed in 7.3.0
- Fix · GHSA-rqq5-2gf9-4w4q secure_headers (RubyGems) Fixed in 7.3.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-54163
- 2026-10-03 Alias added: GHSA-rqq5-2gf9-4w4q
References
Other 6
- https://github.com/github/secure_headers/security/advisories/GHSA-rqq5-2gf9-4w4q
- https://github.com/github/secure_headers/commit/286a79dea80c6a9be4ca93e0f284c923cf77e539
- https://github.com/github/secure_headers/releases/tag/v7.3.0
- https://github.com/github/secure_headers
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/secure_headers/CVE-2026-54163.yml
- https://www.cve.org/CVERecord/SearchResults?query=CVE-2026-54163
More GitHub vulnerabilities
- TI-2024-04632 An authentication bypass vulnerability was present in the GitHub Enterprise Server (GHES)… CVSS 4.0CRITICAL 10.0
- TI-2024-00181 Unsafe Reflection in Github Enterprise Server leading to Command Injection CVSS 3.1CRITICAL 9.8
- TI-2024-00466 Privilege Escalation by Code Injection in the Management Console in GitHub Enterprise Server CVSS 3.1HIGH 8.8
- TI-2022-08539 Integer overflow in table parsing extension leads to heap memory corruption CVSS 3.1CRITICAL 9.8
- TI-2026-34990 GitHub MCP Server: Nil Pointer Dereference DoS in completion/complete Handler CVSS 3.1HIGH 7.5
- TI-2026-32884 GitHub Copilot CLI: Nested Bare Repository Can Execute Arbitrary Commands via core.fsmonitor CVSS 4.0HIGH 8.5
Sources
- CVE-2026-54163 · CVE Program
- CVE-2026-54163 · NVD
- FIRST EPSS
- GHSA-rqq5-2gf9-4w4q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences