Read the docs
TI-2026-40135 Aliases CVE-2026-55599GHSA-m557-wrgg-6rp4

Server-side request forgery in phpseclib

Priority HIGH 65CWE-918Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-918 and the CVSS impact.

Summary

phpseclib is a PHP secure communications library. From 0.1.1 until 1.0.30, 2.0.55, and 3.0.54, when an application validates an untrusted X.509 certificate with phpseclib, X509::validateSignature() reads a URL out of that certificate's Authority Information Access (AIA) extension and connects to it. Attacker who supplies certificate fully controls host, port, and path of that connection. URL fetching is enabled by default, and no destination is blocked. An unauthenticated attacker can therefore make a validating server open connections to internal hosts and ports it should never reach, for example loopback 127.0.0.1, cloud metadata address 169.254.169.254, and internal-only services. This is a server-side request forgery (SSRF) caused by an insecure default. This vulnerability is fixed in 1.0.30, 2.0.55, and 3.0.54.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00213 11th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed phpseclib (phpseclib): 1.0.30, 2.0.55, 3.0.54phpseclib/phpseclib (Packagist): 1.0.30, 2.0.55, 3.0.54

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
phpseclibphpseclib0.1.1 to before 1.0.30; 2.0.0 to before 2.0.55; 3.0.0 to before 3.0.541.0.30, 2.0.55, 3.0.54Patch availableCNA
—phpseclib/phpseclib (Packagist)0.1.1 to before 1.0.301.0.30Patch availableGHSA-m557-wrgg-6rp4
—phpseclib/phpseclib (Packagist)2.0.0 to before 2.0.552.0.55Patch availableGHSA-m557-wrgg-6rp4
—phpseclib/phpseclib (Packagist)3.0.0 to before 3.0.543.0.54Patch availableGHSA-m557-wrgg-6rp4
  • phpseclib Vendorphpseclib Affected 0.1.1 to before 1.0.30; 2.0.0 to before 2.0.55; 3.0.0 to before 3.0.54 Fixed in 1.0.30, 2.0.55, 3.0.54 Patch available CNA
  • phpseclib/phpseclib (Packagist) Vendor— Affected 0.1.1 to before 1.0.30 Fixed in 1.0.30 Patch available GHSA-m557-wrgg-6rp4
  • phpseclib/phpseclib (Packagist) Vendor— Affected 2.0.0 to before 2.0.55 Fixed in 2.0.55 Patch available GHSA-m557-wrgg-6rp4
  • phpseclib/phpseclib (Packagist) Vendor— Affected 3.0.0 to before 3.0.54 Fixed in 3.0.54 Patch available GHSA-m557-wrgg-6rp4

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:phpseclib:phpseclib:*:*:*:*:*:*:*:*0.1.1 to before 1.0.30; 2.0.0 to before 2.0.55; 3.0.0 to before 3.0.54Vulnerablephpseclib
  • cpe:2.3:a:phpseclib:phpseclib:*:*:*:*:*:*:*:* Versions 0.1.1 to before 1.0.30; 2.0.0 to before 2.0.55; 3.0.0 to before 3.0.54 Vulnerable ·phpseclib

Remediation

  • Fix · CNA phpseclib (phpseclib) Fixed in 1.0.30, 2.0.55, 3.0.54
  • Fix · GHSA-m557-wrgg-6rp4 phpseclib/phpseclib (Packagist) Fixed in 1.0.30 Advisory →
  • Fix · GHSA-m557-wrgg-6rp4 phpseclib/phpseclib (Packagist) Fixed in 2.0.55 Advisory →
  • Fix · GHSA-m557-wrgg-6rp4 phpseclib/phpseclib (Packagist) Fixed in 3.0.54 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-55599
  2. 2026-10-03 Alias added: GHSA-m557-wrgg-6rp4

References

  • TI-2026-29008 phpseclib has a variable-time HMAC comparison in SSH2::get_binary_packet() using != instead of hash_equals() CVSS 3.1LOW 3.7
  • TI-2023-29213 In phpseclib before 1.0.22, 2.x before 2.0.46, and 3.x before 3.0.33, some characters in… CVSS 3.1HIGH 7.5
  • TI-2024-18192 An issue was discovered in phpseclib 1.x before 1.0.23, 2.x before 2.0.47, and 3.x before… CVSS 3.1HIGH 7.5
  • TI-2024-18191 An issue was discovered in phpseclib 1.x before 1.0.23, 2.x before 2.0.47, and 3.x before… CVSS 3.1HIGH 7.5
  • TI-2023-12272 Math/PrimeField.php in phpseclib 3.x before 3.0.19 has an infinite loop with composite primefields. CVSS 3.1HIGH 7.5
  • TI-2026-25383 phpseclib's AES-CBC unpadding susceptible to padding oracle timing attack CVSS 4.0HIGH 8.2
See all 8 →

Sources