vLLM - Denial of Service via Unvalidated Multimodal Embeddings
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 4.0 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-502.
Summary
vLLM versions >= 0.10.2 and < 0.13.0 are missing sparse tensor validation in multimodal embeddings processing. Because PyTorch disables sparse tensor invariant checks by default, an attacker can submit crafted embedding requests with malformed (negative or out-of-bounds) tensor indices, when the prompt-embeds feature is enabled, to trigger crashes or resource exhaustion (denial of service), with potential for out-of-bounds/write-what-where memory corruption. This continues CVE-2025-62164, whose prior fix only disabled the feature by default rather than addressing the root cause.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vLLM | vLLM | 0.10.2 to before 0.13.0 | 0.13.0 | Patch available | CNA |
| — | vllm (PyPI) | 0.10.2 to before 0.13.0 | 0.13.0 | Patch available | GHSA-mcmc-2m55-j8jj |
- vLLM VendorvLLM Affected 0.10.2 to before 0.13.0 Fixed in 0.13.0 Patch available CNA
- vllm (PyPI) Vendor— Affected 0.10.2 to before 0.13.0 Fixed in 0.13.0 Patch available GHSA-mcmc-2m55-j8jj
Remediation
- Fix · CNA vLLM (vLLM) Fixed in 0.13.0
- Fix · GHSA-mcmc-2m55-j8jj vllm (PyPI) Fixed in 0.13.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat AI Inference Server | Affected | No fix yet |
Not affected: 3 products
- Red Hat AI Inference Server
- Red Hat Enterprise Linux AI (RHEL AI) 3
- Red Hat OpenShift AI (RHOAI)
Timeline
- 2026-10-02 Threatist record created from CVE-2026-56340
- 2026-10-03 Alias added: GHSA-mcmc-2m55-j8jj
- 2026-10-21 EPSS moved to the 50th–90th percentile
References
Advisory 1
Other 6
- https://github.com/vllm-project/vllm/pull/30649
- https://access.redhat.com/security/cve/CVE-2026-56340
- https://bugzilla.redhat.com/show_bug.cgi?id=2491060
- https://github.com/pypa/advisory-database/tree/main/vulns/vllm/PYSEC-2026-250.yaml
- https://github.com/vllm-project/vllm
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-56340.json
More Vllm vulnerabilities
- TI-2024-10229 Remote Code Execution in vllm-project/vllm CVSS 3.0CRITICAL 9.8
- TI-2026-36017 vLLM: OpenAI auth bypass CVSS 3.1CRITICAL 9.1
- TI-2026-63056 vLLM before 0.28.0 Denial of Service via negative token ID CVSS 4.0HIGH 8.7
- TI-2026-39137 vLLM: Remote DoS in vLLM via Invalid Recovered Token Reinjection CVSS 3.1HIGH 7.5
- TI-2026-04816 Unbounded Frame Count in video/jpeg Base64 Data URL Processing Leads to OOM DoS in vllm-project/vllm CVSS 3.0HIGH 7.5
- TI-2026-65616 vllm-project vLLM Gemma4UnifiedParser gemma4.rs denial of service CVSS 4.0MEDIUM 6.9
Sources
- CVE-2026-56340 · CVE Program
- CVE-2026-56340 · NVD
- FIRST EPSS
- GHSA-mcmc-2m55-j8jj · GitHub Advisory Database · CC BY 4.0
- CVE-2026-56340 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences