GetSimple CMS: Missing CSRF protection in UpdateCE allows forging a privileged server-side update request
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-352.
Summary
GetSimple CMS is a content management system (CMS), and GetSimple CMS CE is the community edition of that CMS. Prior to version 1.5, the UpdateCE update form contained no anti-CSRF token, and the POST handler performed no token or request-origin verification. A remote attacker can host a page that auto-submits a forged POST to the update endpoint; when an authenticated administrator visits it, the server performs an attacker-directed download-and-deploy operation in the administrator's session — with no further interaction. Because the deployed content is executed (see the related ZIP-extraction advisory), this yields remote code execution. The url field is additionally written into the form unescaped, providing a secondary HTML-injection sink via a malicious upgrade.json. This issue has been patched in version 1.5.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GetSimpleCMS-CE | GetSimpleCMS-CE | before 1.5 | 1.5 | Patch available | CNA |
- GetSimpleCMS-CE VendorGetSimpleCMS-CE Affected before 1.5 Fixed in 1.5 Patch available CNA
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:getsimple-ce:getsimple_cms:*:*:*:*:*:*:*:* | — | — | GetSimpleCMS-CE |
- cpe:2.3:a:getsimple-ce:getsimple_cms:*:*:*:*:*:*:*:* Versions — — ·GetSimpleCMS-CE
Remediation
- Fix · CNA GetSimpleCMS-CE (GetSimpleCMS-CE) Fixed in 1.5
Timeline
- 2026-10-02 Threatist record created from CVE-2026-56662
- 2026-10-06 CISA SSVC decision points changed
- 2026-10-06 Priority changed: MEDIUM → HIGH
References
More GetSimpleCMS-CE vulnerabilities
- TI-2024-36775 GetSimple CMS CE 3.3.19 suffers from arbitrary code execution in the template editing… CVSS 3.1CRITICAL 9.8
- TI-2026-38921 GetSimple CMS: Predictable Password Reset Password Allows Administrator Account Takeover CVSS 3.1CRITICAL 9.1
- TI-2025-30771 GetSimple CMS RCE in Edit component CVSS 4.0HIGH 8.6
- TI-2026-40844 GetSimple CMS: CSRF, SSRF, and Unrestricted Zip Extraction CVSS 3.1CRITICAL 9.1
- TI-2024-36777 GetSimple CMS CE 3.3.19 is vulnerable to Server-Side Request Forgery (SSRF) in the backend plugin module. CVSS 3.1HIGH 8.8
- TI-2026-50122 GetSimple CMS: Stored Cross-Site Scripting (XSS) via the "title" parameter in admin/components.php CVSS 4.0HIGH 8.7
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences