phpMyFAQ has Stored XSS in Admin FAQ Editor via HTML Entity Bypass in Frontend FAQ Submission
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
phpMyFAQ is an open source FAQ web application. A stored cross-site scripting (XSS) vulnerability in versions prior to 4.2.0-alpha allows any unauthenticated user (or low-privileged registered user) to inject arbitrary JavaScript that executes in an administrator's browser when they review or edit a user-submitted FAQ entry. This leads to admin account takeover via session theft. The vulnerability exists because `html_entity_decode()` converts HTML entities into executable HTML after `strip_tags()` has already passed them through, and the admin template renders the content with Twig's `|raw` filter without any output sanitization. Version 4.2.0-alpha fixes the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| thorsten | phpMyFAQ | before 4.2.0-alpha | 4.2.0-alpha | Patch available | CNA |
| — | thorsten/phpmyfaq (Packagist) | before 4.2.0-alpha | 4.2.0-alpha | Patch available | GHSA-pgwp-vc7q-cvj3 |
| — | phpmyfaq/phpmyfaq (Packagist) | before 4.2.0-alpha | 4.2.0-alpha | Patch available | GHSA-pgwp-vc7q-cvj3 |
- phpMyFAQ Vendorthorsten Affected before 4.2.0-alpha Fixed in 4.2.0-alpha Patch available CNA
- thorsten/phpmyfaq (Packagist) Vendor— Affected before 4.2.0-alpha Fixed in 4.2.0-alpha Patch available GHSA-pgwp-vc7q-cvj3
- phpmyfaq/phpmyfaq (Packagist) Vendor— Affected before 4.2.0-alpha Fixed in 4.2.0-alpha Patch available GHSA-pgwp-vc7q-cvj3
Remediation
- Fix · CNA phpMyFAQ (thorsten) Fixed in 4.2.0-alpha
- Fix · GHSA-pgwp-vc7q-cvj3 thorsten/phpmyfaq (Packagist) Fixed in 4.2.0-alpha Advisory →
- Fix · GHSA-pgwp-vc7q-cvj3 phpmyfaq/phpmyfaq (Packagist) Fixed in 4.2.0-alpha Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-56736
- 2026-10-03 Alias added: GHSA-pgwp-vc7q-cvj3
References
More thorsten vulnerabilities
- TI-2023-00296 Improper Authentication in thorsten/phpmyfaq CVSS 3.1CRITICAL 9.8
- TI-2026-76118 Authentication bypass in phpMyFAQ via WebAuthn credential injection CVSS 4.0CRITICAL 9.3
- TI-2026-32868 phpMyFAQ - Unauthenticated Two-Factor Authentication Brute-Force via /admin/check Endpoint CVSS 4.0CRITICAL 9.3
- TI-2026-76108 Unauthenticated denial of service in phpMyFAQ API pagination CVSS 4.0HIGH 8.7
- TI-2026-53313 phpMyFAQ 3.1.0 through 4.1.6 Authentication Bypass via LDAP CVSS 4.0HIGH 8.8
- TI-2026-34083 phpMyFAQ - Unauthenticated Information Disclosure via getIdFromSolutionId Permission Bypass CVSS 4.0HIGH 8.7
Sources
- CVE-2026-56736 · CVE Program
- CVE-2026-56736 · NVD
- FIRST EPSS
- GHSA-pgwp-vc7q-cvj3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences