NGINX Plus ngx_stream_mqtt_filter_module vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
When NGINX Plus is configured to use the Message Queuing Telemetry Transport (MQTT) filter module (ngx_stream_mqtt_filter_module), unauthenticated attackers can send requests with conditions beyond the attacker's control to cause a heap buffer over-read in the NGINX worker process, leading to a restart. Impact: This vulnerability may allow remote unauthenticated attackers to have limited control to restart the NGINX worker process. There is no control plane exposure; this is a data plane issue only. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| F5 | NGINX Plus | 37.0.0.1 to before 37.0.3.1; R36 to before R36 P7; R33 and later | 37.0.3.1, R36 P7 | Patch available | CNA |
- NGINX Plus VendorF5 Affected 37.0.0.1 to before 37.0.3.1; R36 to before R36 P7; R33 and later Fixed in 37.0.3.1, R36 P7 Patch available CNA
CPE configurations NVD · 14
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:f5:nginx_gateway_fabric:*:*:*:*:*:*:*:* | 1.3.0 – 1.6.2; 2.0.0 to before 2.6.7 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_ingress_controller:*:*:*:*:continuous_releases:*:*:* | 3.5.0 – 3.7.2; 5.0.0 to before 5.5.3 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_ingress_controller:*:*:*:*:long-term_support:*:*:* | 2026-lts-r1 to before 2026-lts-r4 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_ingress_controller:4.0.0:*:*:*:continuous_releases:*:*:* | 4.0.0 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_ingress_controller:4.0.1:*:*:*:continuous_releases:*:*:* | 4.0.1 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_plus:*:*:*:*:*:*:*:* | 37.0.0.1 to before 37.0.3.1; r33 to before r36 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_plus:r36:-:*:*:*:*:*:* | r36 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_plus:r36:p1:*:*:*:*:*:* | r36 p1 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_plus:r36:p2:*:*:*:*:*:* | r36 p2 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_plus:r36:p3:*:*:*:*:*:* | r36 p3 | Vulnerable | F5 |
- cpe:2.3:a:f5:nginx_gateway_fabric:*:*:*:*:*:*:*:* Versions 1.3.0 – 1.6.2; 2.0.0 to before 2.6.7 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_ingress_controller:*:*:*:*:continuous_releases:*:*:* Versions 3.5.0 – 3.7.2; 5.0.0 to before 5.5.3 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_ingress_controller:*:*:*:*:long-term_support:*:*:* Versions 2026-lts-r1 to before 2026-lts-r4 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_ingress_controller:4.0.0:*:*:*:continuous_releases:*:*:* Versions 4.0.0 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_ingress_controller:4.0.1:*:*:*:continuous_releases:*:*:* Versions 4.0.1 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_plus:*:*:*:*:*:*:*:* Versions 37.0.0.1 to before 37.0.3.1; r33 to before r36 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_plus:r36:-:*:*:*:*:*:* Versions r36 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_plus:r36:p1:*:*:*:*:*:* Versions r36 p1 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_plus:r36:p2:*:*:*:*:*:* Versions r36 p2 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_plus:r36:p3:*:*:*:*:*:* Versions r36 p3 Vulnerable ·F5
Show 4 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:f5:nginx_plus:r36:p4:*:*:*:*:*:* | r36 p4 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_plus:r36:p5:*:*:*:*:*:* | r36 p5 | Vulnerable | F5 |
| cpe:2.3:a:f5:nginx_plus:r36:p6:*:*:*:*:*:* | r36 p6 | Vulnerable | F5 |
| cpe:2.3:a:f5:waf:*:*:*:*:*:nginx:*:* | 4.11.0 – 4.16.0; 5.2.0 – 5.8.0; 5.9.0 to before 5.13.4 | Vulnerable | F5 |
- cpe:2.3:a:f5:nginx_plus:r36:p4:*:*:*:*:*:* Versions r36 p4 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_plus:r36:p5:*:*:*:*:*:* Versions r36 p5 Vulnerable ·F5
- cpe:2.3:a:f5:nginx_plus:r36:p6:*:*:*:*:*:* Versions r36 p6 Vulnerable ·F5
- cpe:2.3:a:f5:waf:*:*:*:*:*:nginx:*:* Versions 4.11.0 – 4.16.0; 5.2.0 – 5.8.0; 5.9.0 to before 5.13.4 Vulnerable ·F5
Remediation
- Fix · CNA NGINX Plus (F5) Fixed in 37.0.3.1, R36 P7
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
F5 NGINX Plus 37.0.3.1, R36 P7
4 records Highest priority Priority HIGH 1 HIGH, 1 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2026-30813 NGINX Map directive and Regex matching vulnerabilityPriority HIGH 75
- TI-2026-42786 NGINX ngx_http_slice_module vulnerabilityPriority MEDIUM 45
- TI-2026-40780 NGINX ngx_http_ssi_module vulnerabilityPriority LOW 37
Timeline
- 2026-10-02 Threatist record created from CVE-2026-60065
- 2026-10-03 Alias added: GHSA-w94h-5qpm-994v
References
More F5 Nginx Gateway Fabric vulnerabilities
- TI-2026-31136 NGINX ngx_http_rewrite_module vulnerability CVSS 4.0CRITICAL 9.2
- TI-2026-30813 NGINX Map directive and Regex matching vulnerability CVSS 4.0CRITICAL 9.2
- TI-2026-08132 NGINX ngx_http_rewrite_module vulnerability CVSS 4.0CRITICAL 9.2
- TI-2026-30812 NGINX Open-Source ngx_http_v3_module vulnerability CVSS 4.0CRITICAL 9.2
- TI-2026-30432 NGINX ngx_http_proxy_v2_module and ngx_http_grpc_module vulnerability CVSS 4.0CRITICAL 9.2
- TI-2026-42786 NGINX ngx_http_slice_module vulnerability CVSS 4.0HIGH 8.8
Sources
- CVE-2026-60065 · CVE Program
- CVE-2026-60065 · NVD
- FIRST EPSS
- GHSA-w94h-5qpm-994v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences