OpenRemote before 1.26.2 Information Disclosure via Syslog REST API
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-200.
Summary
OpenRemote versions before 1.26.2 contain an information disclosure vulnerability in the SyslogResource REST endpoint that fails to filter operational logs by realm. Attackers with the read:rules role can access the GET /api/{realm}/syslog/event endpoint to retrieve operational logs from all tenants, exposing asset IDs, agent connection details, rule names, and protocol errors across the multi-tenant deployment.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| openremote | openremote | before 1.26.2 | 1.26.2 | Patch available | CNA |
- openremote Vendoropenremote Affected before 1.26.2 Fixed in 1.26.2 Patch available CNA
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:openremote:openremote:*:*:*:*:*:*:*:* | — | — | openremote |
- cpe:2.3:a:openremote:openremote:*:*:*:*:*:*:*:* Versions — — ·openremote
Remediation
- Fix · CNA openremote (openremote) Fixed in 1.26.2
Timeline
- 2026-10-02 Threatist record created from CVE-2026-65009
- 2026-10-03 Alias added: GHSA-fvrm-x822-jhc4
References
More openremote vulnerabilities
- TI-2022-13714 An issue was discovered in OpenRemote through 1.0.4 allows attackers to execute arbitrary… CVSS 3.1CRITICAL 9.8
- TI-2026-28724 OpenRemote is Vulnerable to Expression Injection CVSS 3.1CRITICAL 10.0
- TI-2026-79160 Missing authorization in OpenRemote gateway tunnel endpoints CVSS 4.0CRITICAL 9.0
- TI-2026-40948 OpenRemote < 1.25.0 IDOR via Bulk Alarm Deletion Endpoint CVSS 4.0HIGH 8.6
- TI-2026-71893 OpenRemote: Cross-Realm User Information Disclosure in UserResourceImpl CVSS 3.1HIGH 7.7
- TI-2026-29790 OpenRemote has Improper Access Control via updateUserRealmRoles function CVSS 3.1HIGH 7.0
Sources
- CVE-2026-65009 · CVE Program
- CVE-2026-65009 · NVD
- FIRST EPSS
- GHSA-fvrm-x822-jhc4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences