phpMyFAQ before 4.1.6 Remote Code Execution via Configuration API
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-494.
Summary
phpMyFAQ before v4.1.6 contains a remote code execution vulnerability in the configuration API that allows authenticated administrators with CONFIGURATION_EDIT and ATTACHMENT_ADD privileges to write arbitrary PHP files by manipulating the upgrade.lastDownloadedPackage setting. Attackers can upload a malicious ZIP file as an attachment, point the updater configuration to its stored path, and extract it into the application root to achieve code execution as the web server user.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA phpMyFAQ (thorsten) Fixed in 4.1.6
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
thorsten phpMyFAQ 4.1.6
3 records Highest priority Priority HIGH 3 HIGH
Other records, highest priority first
- TI-2026-47158 phpMyFAQ before 4.1.6 Privilege Escalation via Group MembershipPriority HIGH 72
- TI-2026-47156 phpMyFAQ before 4.1.6 Path Traversal via category image deletionPriority HIGH 72
Timeline
- 2026-10-02 Threatist record created from CVE-2026-66398
- 2026-10-03 Alias added: GHSA-c4f8-v76x-mwx3
References
More thorsten vulnerabilities
- TI-2023-00296 Improper Authentication in thorsten/phpmyfaq CVSS 3.1CRITICAL 9.8
- TI-2026-76118 Authentication bypass in phpMyFAQ via WebAuthn credential injection CVSS 4.0CRITICAL 9.3
- TI-2026-32868 phpMyFAQ - Unauthenticated Two-Factor Authentication Brute-Force via /admin/check Endpoint CVSS 4.0CRITICAL 9.3
- TI-2026-76108 Unauthenticated denial of service in phpMyFAQ API pagination CVSS 4.0HIGH 8.7
- TI-2026-53313 phpMyFAQ 3.1.0 through 4.1.6 Authentication Bypass via LDAP CVSS 4.0HIGH 8.8
- TI-2026-34083 phpMyFAQ - Unauthenticated Information Disclosure via getIdFromSolutionId Permission Bypass CVSS 4.0HIGH 8.7
Sources
- CVE-2026-66398 · CVE Program
- CVE-2026-66398 · NVD
- FIRST EPSS
- GHSA-c4f8-v76x-mwx3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences