Craft CMS 5.0.0-RC1 before 5.10.6 Path Traversal via ensurePathIsContained
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.
Summary
Craft CMS versions >= 5.0.0-RC1 before 5.10.6 and >= 4.0.0-RC1 before 4.18.2 contain a theoretical path traversal weakness in the ensurePathIsContained function of the Local file system class. The order of operations validates the path before normalization, so normalization could invalidate prior validation assumptions (a desanitization-style issue) and potentially resolve to files outside the intended volume directory. The vendor notes the issue is not directly exploitable and no exploitable scenario has been discovered; the fix is recommended for hardening.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Craft CMS | cms | 5.0.0-RC1 to before 5.10.6 | 5.10.6 | Patch available | CNA |
| Craft CMS | cms | 4.0.0-RC1 to before 4.18.2 | 4.18.2 | Patch available | CNA |
| — | craftcms/cms (Packagist) | 5.0.0-RC1 to before 5.10.6 | 5.10.6 | Patch available | GHSA-7hxc-f267-h5q7 |
| — | craftcms/cms (Packagist) | 4.0.0-RC1 to before 4.18.2 | 4.18.2 | Patch available | GHSA-7hxc-f267-h5q7 |
- cms VendorCraft CMS Affected 5.0.0-RC1 to before 5.10.6 Fixed in 5.10.6 Patch available CNA
- cms VendorCraft CMS Affected 4.0.0-RC1 to before 4.18.2 Fixed in 4.18.2 Patch available CNA
- craftcms/cms (Packagist) Vendor— Affected 5.0.0-RC1 to before 5.10.6 Fixed in 5.10.6 Patch available GHSA-7hxc-f267-h5q7
- craftcms/cms (Packagist) Vendor— Affected 4.0.0-RC1 to before 4.18.2 Fixed in 4.18.2 Patch available GHSA-7hxc-f267-h5q7
Remediation
- Fix · CNA cms (craftcms) Fixed in 5.10.6
- Fix · CNA cms (craftcms) Fixed in 4.18.2
- Fix · GHSA-7hxc-f267-h5q7 craftcms/cms (Packagist) Fixed in 5.10.6 Advisory →
- Fix · GHSA-7hxc-f267-h5q7 craftcms/cms (Packagist) Fixed in 4.18.2 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
craftcms cms 5.10.6
6 records Highest priority Priority MEDIUM 2 MEDIUM, 4 LOW
Other records, highest priority first
- TI-2026-51004 Craft CMS 5.0.0-RC1 before 5.10.6 Authenticated RCE via condition.configPriority MEDIUM 41
- TI-2026-51011 Craft CMS before 5.10.6 Authorization Bypass via structures/move-elementPriority MEDIUM 40
- TI-2026-51005 Craft CMS 5.0.0-RC1 before 5.10.6 Arbitrary File Read via SplFileObjectPriority LOW 38
- Release ·
craftcms cms 4.18.2
5 records Highest priority Priority MEDIUM 1 MEDIUM, 4 LOW
Other records, highest priority first
- TI-2026-51004 Craft CMS 5.0.0-RC1 before 5.10.6 Authenticated RCE via condition.configPriority MEDIUM 41
- TI-2026-51005 Craft CMS 5.0.0-RC1 before 5.10.6 Arbitrary File Read via SplFileObjectPriority LOW 38
- TI-2026-51008 Craft CMS 5.0.0-RC1 before 5.10.6 Environment Variable LeakPriority LOW 31
Timeline
- 2026-10-02 Threatist record created from CVE-2026-72783
- 2026-10-03 Alias added: GHSA-7hxc-f267-h5q7
References
Advisory 2
More Craft CMS vulnerabilities
- TI-2025-23503 Craft CMS Allows Remote Code Execution KEVCVSS 3.1CRITICAL 10.0
- TI-2024-37138 RCE when PHP `register_argc_argv` config setting is enabled in craftcms/cms KEVCVSS 4.0CRITICAL 9.3
- TI-2025-16994 Potential RCE with a compromised security key in craft/cms KEVCVSS 3.1HIGH 8.1
- TI-2025-24595 Craft CMS stores user-provided content in session files KEVCVSS 4.0MEDIUM 6.9
- TI-2023-22284 Craft CMS Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
- TI-2024-25171 Craft CMS up to v3.7.31 was discovered to contain a SQL injection vulnerability via the GraphQL API endpoint. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-72783 · CVE Program
- CVE-2026-72783 · NVD
- FIRST EPSS
- GHSA-7hxc-f267-h5q7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences