Next.js: Unauthenticated Remote Code Execution on windows-hosted servers
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Next.js is a React framework for building full-stack web applications. From 13.4.0 until 15.5.24 and 16.3.3, Next.js applications using Pages Router or App Router without Cache Components on Windows-hosted servers do not consistently escape backslashes in route segments before constructing incremental-cache paths. In packages/next/src/shared/lib/router/utils/escape-path-delimiters.ts and packages/next/src/server/lib/incremental-cache/file-system-cache.ts, a remote request can supply encoded Windows path separators that traverse outside the intended cache root and expose private build data, including the server-reference-manifest encryption key. Disclosure of that key can enable remote code execution in the affected application. This issue is fixed in versions 15.5.24 and 16.3.3.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vercel | next.js | 13.4.0 to before 15.5.24; 16.0.0 to before 16.3.3 | 15.5.24, 16.3.3 | Patch available | CNA |
| — | next (npm) | 13.4.0 to before 15.5.24 | 15.5.24 | Patch available | GHSA-p293-qw3h-jr36 |
| — | next (npm) | 16.0.0 to before 16.3.3 | 16.3.3 | Patch available | GHSA-p293-qw3h-jr36 |
- next.js Vendorvercel Affected 13.4.0 to before 15.5.24; 16.0.0 to before 16.3.3 Fixed in 15.5.24, 16.3.3 Patch available CNA
- next (npm) Vendor— Affected 13.4.0 to before 15.5.24 Fixed in 15.5.24 Patch available GHSA-p293-qw3h-jr36
- next (npm) Vendor— Affected 16.0.0 to before 16.3.3 Fixed in 16.3.3 Patch available GHSA-p293-qw3h-jr36
Remediation
- Fix · CNA next.js (vercel) Fixed in 15.5.24, 16.3.3
- Fix · GHSA-p293-qw3h-jr36 next (npm) Fixed in 15.5.24 Advisory →
- Fix · GHSA-p293-qw3h-jr36 next (npm) Fixed in 16.3.3 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Critical. Red Hat's page for this CVE →
Not affected: 6 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
- Red Hat Enterprise Linux AI (RHEL AI) 3
- Red Hat Trusted Artifact Signer
Timeline
- 2026-10-02 Threatist record created from CVE-2026-75604
- 2026-10-03 Alias added: GHSA-p293-qw3h-jr36
- 2026-10-05 Affected versions changed · Red Hat
- 2026-10-05 CVSS score added · Red Hat
References
Other 6
- https://github.com/vercel/next.js/security/advisories/GHSA-p293-qw3h-jr36
- https://github.com/vercel/next.js/commit/968b9fcb26bdeb8e0a861a9df05361474666d51b
- https://github.com/vercel/next.js/commit/b0f3460a92b955d3ca41fccff9a525a2b910fbf3
- https://github.com/vercel/next.js/releases/tag/v15.5.24
- https://github.com/vercel/next.js/releases/tag/v16.3.3
- https://github.com/vercel/next.js
More vercel vulnerabilities
- TI-2025-34861 Deserialization of untrusted data in Meta react-server-dom-webpack KEVCVSS 3.1CRITICAL 10.0
- TI-2025-21309 Authorization Bypass in Next.js Middleware CVSS 3.1CRITICAL 9.1
- TI-2024-15745 An issue in Hyper on macOS version 3.4.1 and before, allows remote attackers to execute… CVSS 3.1CRITICAL 9.8
- TI-2025-34863 Deserialization of untrusted data in Meta react-server-dom-webpack CVSS 3.1HIGH 7.5
- TI-2024-31371 Cache Poisoning in next.js CVSS 3.1HIGH 7.5
- TI-2023-24914 Next.js before 13.4.20-canary.13 lacks a cache-control header and thus empty prefetch… CVSS 3.1HIGH 7.5
Sources
- CVE-2026-75604 · CVE Program
- CVE-2026-75604 · NVD
- FIRST EPSS
- GHSA-p293-qw3h-jr36 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-75604 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences