CodeWhale before 0.8.64 Remote Code Execution via allow_shell
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
CodeWhale versions before 0.8.64 fail to properly validate the allow_shell configuration parameter from project config files, allowing attackers to enable arbitrary shell command execution by committing a malicious .codewhale/config.toml file to a repository. When a user clones and opens the repository in CodeWhale, the AI model gains access to exec_shell and task_shell tools, enabling execution of arbitrary shell commands on the victim's machine without explicit user consent.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Hmbown | CodeWhale | 0.8.6 to before 0.8.41 | 0.8.41 | Patch available | CNA |
| Hmbown | CodeWhale | 0.8.6 to before 0.8.41 | 0.8.41 | Patch available | CNA |
| Hmbown | CodeWhale | 0.8.41 to before 0.8.64 | 0.8.64 | Patch available | CNA |
| Hmbown | CodeWhale | 0.8.41 to before 0.8.64 | 0.8.64 | Patch available | CNA |
| — | deepseek-tui (crates.io) | 0.8.6 – 0.8.41 | — | No fix listed | GHSA-gx45-xrj5-g6c4 |
| — | deepseek-tui (npm) | 0.8.6 to before 0.8.41 | 0.8.41 | Patch available | GHSA-gx45-xrj5-g6c4 |
| — | codewhale-tui (crates.io) | 0.8.41 to before 0.8.64 | 0.8.64 | Patch available | GHSA-gx45-xrj5-g6c4 |
| — | codewhale (npm) | 0.8.41 to before 0.8.64 | 0.8.64 | Patch available | GHSA-gx45-xrj5-g6c4 |
- CodeWhale VendorHmbown Affected 0.8.6 to before 0.8.41 Fixed in 0.8.41 Patch available CNA
- CodeWhale VendorHmbown Affected 0.8.6 to before 0.8.41 Fixed in 0.8.41 Patch available CNA
- CodeWhale VendorHmbown Affected 0.8.41 to before 0.8.64 Fixed in 0.8.64 Patch available CNA
- CodeWhale VendorHmbown Affected 0.8.41 to before 0.8.64 Fixed in 0.8.64 Patch available CNA
- deepseek-tui (crates.io) Vendor— Affected 0.8.6 – 0.8.41 Fixed in — No fix listed GHSA-gx45-xrj5-g6c4
- deepseek-tui (npm) Vendor— Affected 0.8.6 to before 0.8.41 Fixed in 0.8.41 Patch available GHSA-gx45-xrj5-g6c4
- codewhale-tui (crates.io) Vendor— Affected 0.8.41 to before 0.8.64 Fixed in 0.8.64 Patch available GHSA-gx45-xrj5-g6c4
- codewhale (npm) Vendor— Affected 0.8.41 to before 0.8.64 Fixed in 0.8.64 Patch available GHSA-gx45-xrj5-g6c4
Remediation
- Fix · CNA CodeWhale (Hmbown) Fixed in 0.8.41
- Fix · CNA CodeWhale (Hmbown) Fixed in 0.8.41
- Fix · CNA CodeWhale (Hmbown) Fixed in 0.8.64
- Fix · CNA CodeWhale (Hmbown) Fixed in 0.8.64
- Fix · GHSA-gx45-xrj5-g6c4 deepseek-tui (npm) Fixed in 0.8.41 Advisory →
- Fix · GHSA-gx45-xrj5-g6c4 codewhale-tui (crates.io) Fixed in 0.8.64 Advisory →
- Fix · GHSA-gx45-xrj5-g6c4 codewhale (npm) Fixed in 0.8.64 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Hmbown CodeWhale 0.8.41, 0.8.64
9 records Highest priority Priority HIGH 7 HIGH, 2 MEDIUM
Other records, highest priority first
- TI-2026-53100 CodeWhale before 0.8.64 SSRF Bypass via DNS Pinning TOCTOUPriority HIGH 79
- TI-2026-53143 CodeWhale before 0.8.64 Environment Variable Leak via js_executionPriority HIGH 77
- TI-2026-53141 CodeWhale before 0.8.64 Argument Injection via git_showPriority HIGH 72
Timeline
- 2026-10-02 Threatist record created from CVE-2026-75911
- 2026-10-03 Alias added: GHSA-gx45-xrj5-g6c4
References
More Hmbown vulnerabilities
- TI-2026-53100 CodeWhale before 0.8.64 SSRF Bypass via DNS Pinning TOCTOU CVSS 4.0CRITICAL 9.2
- TI-2026-53143 CodeWhale before 0.8.64 Environment Variable Leak via js_execution CVSS 4.0HIGH 8.7
- TI-2026-33165 CodeWhale: task_create Insecure Defaults Enable RCE via Prompt Injection in Project Files CVSS 3.1CRITICAL 9.6
- TI-2026-33110 CodeWhale: run_tests Tool Enables RCE via Malicious Repository Without Approval CVSS 3.1CRITICAL 9.6
- TI-2026-53141 CodeWhale before 0.8.64 Argument Injection via git_show CVSS 4.0HIGH 8.5
- TI-2026-53102 CodeWhale rlm_eval before 0.8.64 Remote Code Execution CVSS 4.0HIGH 8.5
Sources
- CVE-2026-75911 · CVE Program
- CVE-2026-75911 · NVD
- FIRST EPSS
- GHSA-gx45-xrj5-g6c4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences