CodeWhale before 0.8.64 Environment Variable Leak via js_execution
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
CodeWhale versions before 0.8.64 contain an environment variable exposure vulnerability in the js_execution tool that fails to scrub parent process environment variables before spawning Node.js. Attackers can craft malicious JavaScript code executed by the tool to read process.env and leak API keys, cloud credentials, and authentication tokens back to the model context.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Hmbown | CodeWhale | 0.8.32 to before 0.8.41 | 0.8.41 | Patch available | CNA |
| Hmbown | CodeWhale | 0.8.32 to before 0.8.41 | 0.8.41 | Patch available | CNA |
| Hmbown | CodeWhale | 0.8.41 to before 0.8.64 | 0.8.64 | Patch available | CNA |
| Hmbown | CodeWhale | 0.8.41 to before 0.8.64 | 0.8.64 | Patch available | CNA |
| — | deepseek-tui (crates.io) | 0.8.32 – 0.8.41 | — | No fix listed | GHSA-h539-c7r8-3xq4 |
| — | deepseek-tui (npm) | 0.8.32 to before 0.8.41 | 0.8.41 | Patch available | GHSA-h539-c7r8-3xq4 |
| — | codewhale-tui (crates.io) | 0.8.41 to before 0.8.64 | 0.8.64 | Patch available | GHSA-h539-c7r8-3xq4 |
| — | codewhale (npm) | 0.8.41 to before 0.8.64 | 0.8.64 | Patch available | GHSA-h539-c7r8-3xq4 |
- CodeWhale VendorHmbown Affected 0.8.32 to before 0.8.41 Fixed in 0.8.41 Patch available CNA
- CodeWhale VendorHmbown Affected 0.8.32 to before 0.8.41 Fixed in 0.8.41 Patch available CNA
- CodeWhale VendorHmbown Affected 0.8.41 to before 0.8.64 Fixed in 0.8.64 Patch available CNA
- CodeWhale VendorHmbown Affected 0.8.41 to before 0.8.64 Fixed in 0.8.64 Patch available CNA
- deepseek-tui (crates.io) Vendor— Affected 0.8.32 – 0.8.41 Fixed in — No fix listed GHSA-h539-c7r8-3xq4
- deepseek-tui (npm) Vendor— Affected 0.8.32 to before 0.8.41 Fixed in 0.8.41 Patch available GHSA-h539-c7r8-3xq4
- codewhale-tui (crates.io) Vendor— Affected 0.8.41 to before 0.8.64 Fixed in 0.8.64 Patch available GHSA-h539-c7r8-3xq4
- codewhale (npm) Vendor— Affected 0.8.41 to before 0.8.64 Fixed in 0.8.64 Patch available GHSA-h539-c7r8-3xq4
Remediation
- Fix · CNA CodeWhale (Hmbown) Fixed in 0.8.41
- Fix · CNA CodeWhale (Hmbown) Fixed in 0.8.41
- Fix · CNA CodeWhale (Hmbown) Fixed in 0.8.64
- Fix · CNA CodeWhale (Hmbown) Fixed in 0.8.64
- Fix · GHSA-h539-c7r8-3xq4 deepseek-tui (npm) Fixed in 0.8.41 Advisory →
- Fix · GHSA-h539-c7r8-3xq4 codewhale-tui (crates.io) Fixed in 0.8.64 Advisory →
- Fix · GHSA-h539-c7r8-3xq4 codewhale (npm) Fixed in 0.8.64 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Hmbown CodeWhale 0.8.41, 0.8.64
9 records Highest priority Priority HIGH 7 HIGH, 2 MEDIUM
Other records, highest priority first
- TI-2026-53100 CodeWhale before 0.8.64 SSRF Bypass via DNS Pinning TOCTOUPriority HIGH 79
- TI-2026-53141 CodeWhale before 0.8.64 Argument Injection via git_showPriority HIGH 72
- TI-2026-53139 CodeWhale before 0.8.64 Remote Code Execution via allow_shellPriority HIGH 72
Timeline
- 2026-10-02 Threatist record created from CVE-2026-75915
- 2026-10-03 Alias added: GHSA-h539-c7r8-3xq4
References
More Hmbown vulnerabilities
- TI-2026-53100 CodeWhale before 0.8.64 SSRF Bypass via DNS Pinning TOCTOU CVSS 4.0CRITICAL 9.2
- TI-2026-33165 CodeWhale: task_create Insecure Defaults Enable RCE via Prompt Injection in Project Files CVSS 3.1CRITICAL 9.6
- TI-2026-33110 CodeWhale: run_tests Tool Enables RCE via Malicious Repository Without Approval CVSS 3.1CRITICAL 9.6
- TI-2026-53141 CodeWhale before 0.8.64 Argument Injection via git_show CVSS 4.0HIGH 8.5
- TI-2026-53139 CodeWhale before 0.8.64 Remote Code Execution via allow_shell CVSS 4.0HIGH 8.5
- TI-2026-53102 CodeWhale rlm_eval before 0.8.64 Remote Code Execution CVSS 4.0HIGH 8.5
Sources
- CVE-2026-75915 · CVE Program
- CVE-2026-75915 · NVD
- FIRST EPSS
- GHSA-h539-c7r8-3xq4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences