Read the docs

Hmbown

Records13All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical3CVSS 9.0–10.0
CVSS high10CVSS 7.0–8.9

Exploited now

Hmbown records in CISA KEV

No Hmbown vulnerabilities are listed in CISA KEV.

Records

13 records

Priority HIGH 79

CodeWhale before 0.8.64 contains a server-side request forgery bypass vulnerability in DNS pinning logic that fails to prevent time-of-check-time-of-use attacks.

CVSS 4.0CRITICAL 9.2 Network No auth No interaction EPSS 0.00495 Published 2026-08-18 Fixed in 0.8.41, 0.8.64 CWE-918
Priority HIGH 77

CodeWhale versions before 0.8.64 contain an environment variable exposure vulnerability in the js_execution tool that fails to scrub parent process environment variables before spawning Node.js.

CVSS 4.0HIGH 8.7 Network No auth No interaction EPSS 0.00678 Published 2026-08-18 Fixed in 0.8.41, 0.8.64 CWE-200
Priority HIGH 72

CodeWhale versions >= 0.3.27 and < 0.8.64 (published as deepseek-tui >= 0.3.27 and < 0.8.41 on npm and 0.3.27 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain an argument inje…

CVSS 4.0HIGH 8.5 Network No auth User interaction EPSS 0.00477 Published 2026-08-18 Fixed in 0.8.41, 0.8.64 CWE-73
Priority HIGH 72

CodeWhale versions before 0.8.64 fail to properly validate the allow_shell configuration parameter from project config files, allowing attackers to enable arbitrary shell command execution by committing a malicious .code…

CVSS 4.0HIGH 8.5 Local No auth User interaction EPSS 0.00246 Published 2026-08-18 Fixed in 0.8.41, 0.8.64 CWE-94
Priority HIGH 72

CodeWhale (packages codewhale / codewhale-tui) versions >= 0.8.41 and < 0.8.64 contain a remote code execution vulnerability in the rlm_eval tool.

CVSS 4.0HIGH 8.5 Local No auth User interaction EPSS 0.00364 Published 2026-08-18 Fixed in 0.8.41, 0.8.64 CWE-94
Priority HIGH 69

CodeWhale versions before 0.8.64 contain an argument injection vulnerability in the git_blame tool that allows attackers to read arbitrary files by injecting git options into the unvalidated rev parameter.

CVSS 4.0HIGH 8.3 Network No auth User interaction EPSS 0.00446 Published 2026-08-18 Fixed in 0.8.41, 0.8.64 CWE-88
TI-2026-33164 CVE-2026-45373 · GHSA-88gh-2526-gfrr

CodeWhale: SSRF‌ IPV6 bypass

Priority HIGH 68

CodeWhale is a DeepSeek + MiMo coding agent in terminal.

CVSS 3.1HIGH 7.4 Network No auth User interaction EPSS 0.00303 Published 2026-05-28 Fixed in 0.8.26 CWE-918
Priority HIGH 67

CodeWhale versions >= 0.3.10 and < 0.8.64 (published as deepseek-tui >= 0.3.10 and < 0.8.41 on npm and 0.3.10 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain a vulnerability…

CVSS 4.0HIGH 7.3 Local No auth User interaction EPSS 0.00155 Published 2026-08-18 Fixed in 0.8.41, 0.8.64 CWE-269
Priority MEDIUM 44

CodeWhale versions before 0.8.64 contain a path traversal vulnerability in the image_analyze tool that fails to canonicalize symlinks before reading files.

CVSS 4.0HIGH 8.7 Network No auth No interaction EPSS 0.0053 Published 2026-08-18 Fixed in 0.8.41, 0.8.64 CWE-22
Priority MEDIUM 44

CodeWhale versions before 0.8.64 fail to validate file paths in the project config instructions field, allowing attackers to read arbitrary files on the victim's system.

CVSS 4.0HIGH 8.7 Network No auth No interaction EPSS 0.0053 Published 2026-08-18 Fixed in 0.8.41, 0.8.64 CWE-22
Open these records in search →