Read the docs
TI-2026-54106 Aliases CVE-2026-77635GHSA-fxf7-vhh8-7vpq

CakePHP: FunctionsBuilder::jsonValue() vulerable to SQL injection with PostgresDriver

Priority MEDIUM 48CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · Low
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-89.

Summary

CakePHP is a rapid development framework for PHP. Prior to versions 5.1.10, 5.2.15, and 5.3.7 on their respective release lines, FunctionsBuilder::jsonValue() with PostgresDriver is vulnerable to SQL injection when user-controlled data is supplied to the jsonPath parameter. This issue is fixed in versions 5.1.10, 5.2.15, and 5.3.7.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00493 42nd percentileScored 2026-11-07
Fix Fixed cakephp (cakephp): 5.1.10, 5.2.15, 5.3.7cakephp/database (cakephp): 5.1.10, 5.2.15, 5.3.7+2 more products

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
cakephpcakephp5.1.0 to before 5.1.10; 5.2.0 to before 5.2.15; 5.3.0 to before 5.3.75.1.10, 5.2.15, 5.3.7Patch availableCNA
cakephpcakephp/database5.1.0 to before 5.1.10; 5.2.0 to before 5.2.15; 5.3.0 to before 5.3.75.1.10, 5.2.15, 5.3.7Patch availableCNA
—cakephp/cakephp (Packagist)5.3.0 to before 5.3.75.3.7Patch availableGHSA-fxf7-vhh8-7vpq
—cakephp/cakephp (Packagist)5.2.0 to before 5.2.155.2.15Patch availableGHSA-fxf7-vhh8-7vpq
—cakephp/cakephp (Packagist)5.1.0 to before 5.1.105.1.10Patch availableGHSA-fxf7-vhh8-7vpq
—cakephp/database (Packagist)5.3.0 to before 5.3.75.3.7Patch availableGHSA-fxf7-vhh8-7vpq
—cakephp/database (Packagist)5.2.0 to before 5.2.155.2.15Patch availableGHSA-fxf7-vhh8-7vpq
—cakephp/database (Packagist)5.1.0 to before 5.1.105.1.10Patch availableGHSA-fxf7-vhh8-7vpq
  • cakephp Vendorcakephp Affected 5.1.0 to before 5.1.10; 5.2.0 to before 5.2.15; 5.3.0 to before 5.3.7 Fixed in 5.1.10, 5.2.15, 5.3.7 Patch available CNA
  • cakephp/database Vendorcakephp Affected 5.1.0 to before 5.1.10; 5.2.0 to before 5.2.15; 5.3.0 to before 5.3.7 Fixed in 5.1.10, 5.2.15, 5.3.7 Patch available CNA
  • cakephp/cakephp (Packagist) Vendor— Affected 5.3.0 to before 5.3.7 Fixed in 5.3.7 Patch available GHSA-fxf7-vhh8-7vpq
  • cakephp/cakephp (Packagist) Vendor— Affected 5.2.0 to before 5.2.15 Fixed in 5.2.15 Patch available GHSA-fxf7-vhh8-7vpq
  • cakephp/cakephp (Packagist) Vendor— Affected 5.1.0 to before 5.1.10 Fixed in 5.1.10 Patch available GHSA-fxf7-vhh8-7vpq
  • cakephp/database (Packagist) Vendor— Affected 5.3.0 to before 5.3.7 Fixed in 5.3.7 Patch available GHSA-fxf7-vhh8-7vpq
  • cakephp/database (Packagist) Vendor— Affected 5.2.0 to before 5.2.15 Fixed in 5.2.15 Patch available GHSA-fxf7-vhh8-7vpq
  • cakephp/database (Packagist) Vendor— Affected 5.1.0 to before 5.1.10 Fixed in 5.1.10 Patch available GHSA-fxf7-vhh8-7vpq

Remediation

  • Fix · CNA cakephp (cakephp) Fixed in 5.1.10, 5.2.15, 5.3.7
  • Fix · CNA cakephp/database (cakephp) Fixed in 5.1.10, 5.2.15, 5.3.7
  • Fix · GHSA-fxf7-vhh8-7vpq cakephp/cakephp (Packagist) Fixed in 5.3.7 Advisory →
  • Fix · GHSA-fxf7-vhh8-7vpq cakephp/cakephp (Packagist) Fixed in 5.2.15 Advisory →
  • Fix · GHSA-fxf7-vhh8-7vpq cakephp/cakephp (Packagist) Fixed in 5.1.10 Advisory →
  • Fix · GHSA-fxf7-vhh8-7vpq cakephp/database (Packagist) Fixed in 5.3.7 Advisory →
  • Fix · GHSA-fxf7-vhh8-7vpq cakephp/database (Packagist) Fixed in 5.2.15 Advisory →
  • Fix · GHSA-fxf7-vhh8-7vpq cakephp/database (Packagist) Fixed in 5.1.10 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-77635
  2. 2026-10-03 Alias added: GHSA-fxf7-vhh8-7vpq

References

  • TI-2010-04068 The _validatePost function in libs/controller/components/security.php in CakePHP 1.3.x… CVSS 2.0HIGH 7.5
  • TI-2026-82995 Cookie leakage in CakePHP HTTP client cookie domain matching CVSS 4.0MEDIUM 6.3
  • TI-2026-19037 CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting CVSS 3.1MEDIUM 5.4
  • TI-2023-08901 Database Query::offset() and limit() vulnerable to SQL injection in cakephp CVSS 3.1CRITICAL 9.8
  • TI-2026-55232 CakePHP: Multiple methods in FunctionsBuilder vulnerable to SQL injection CVSS 4.0CRITICAL 9.2
  • TI-2026-82998 SQL injection in CakePHP via unvalidated collation names CVSS 4.0CRITICAL 9.2
See all 22 →

Sources