CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting
Priority MEDIUM 58CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
CakePHP is a rapid development framework for PHP. The PaginatorHelper::limitControl() method has a cross-site-scripting vulnerability via query string parameter manipulation. This issue has been fixed in 5.2.12 and 5.3.1.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00281 20th percentileScored 2026-11-07
Fix Fixed cakephp (cakephp): 5.2.12, 5.3.1cakephp/cakephp (Packagist): 5.2.12, 5.3.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| cakephp | cakephp | 5.2.10 to before 5.2.12; 5.3.0 to before 5.3.1 | 5.2.12, 5.3.1 | Patch available | CNA |
| — | cakephp/cakephp (Packagist) | 5.2.10 to before 5.2.12 | 5.2.12 | Patch available | GHSA-qh8m-9qxx-53m5 |
| — | cakephp/cakephp (Packagist) | 5.3.0 to before 5.3.1 | 5.3.1 | Patch available | GHSA-qh8m-9qxx-53m5 |
- cakephp Vendorcakephp Affected 5.2.10 to before 5.2.12; 5.3.0 to before 5.3.1 Fixed in 5.2.12, 5.3.1 Patch available CNA
- cakephp/cakephp (Packagist) Vendor— Affected 5.2.10 to before 5.2.12 Fixed in 5.2.12 Patch available GHSA-qh8m-9qxx-53m5
- cakephp/cakephp (Packagist) Vendor— Affected 5.3.0 to before 5.3.1 Fixed in 5.3.1 Patch available GHSA-qh8m-9qxx-53m5
Remediation
- Fix · CNA cakephp (cakephp) Fixed in 5.2.12, 5.3.1
- Fix · GHSA-qh8m-9qxx-53m5 cakephp/cakephp (Packagist) Fixed in 5.2.12 Advisory →
- Fix · GHSA-qh8m-9qxx-53m5 cakephp/cakephp (Packagist) Fixed in 5.3.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-23643
- 2026-10-03 Alias added: GHSA-qh8m-9qxx-53m5
References
Advisory 2
More Cakephp vulnerabilities
- TI-2010-04068 The _validatePost function in libs/controller/components/security.php in CakePHP 1.3.x… CVSS 2.0HIGH 7.5
- TI-2023-08901 Database Query::offset() and limit() vulnerable to SQL injection in cakephp CVSS 3.1CRITICAL 9.8
- TI-2016-04142 The clientIp function in CakePHP 3.2.4 and earlier allows remote attackers to spoof their… CVSS 3.0HIGH 7.5
- TI-2015-06899 CakePHP 2.x and 3.x before 3.1.5 might allow remote attackers to bypass the CSRF… CVSS 3.0HIGH 8.8
- TI-2020-17913 A vulnerability exists in CakePHP versions 4.0.x through 4.1.3. CVSS 3.1HIGH 8.8
- TI-2019-08553 An issue was discovered in SmtpTransport in CakePHP 3.7.6. CVSS 3.0HIGH 7.5
Sources
- CVE-2026-23643 · CVE Program
- CVE-2026-23643 · NVD
- FIRST EPSS
- GHSA-qh8m-9qxx-53m5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences