Read the docs
TI-2026-56333 Aliases CVE-2026-81679GHSA-fgj3-5frq-8vw8

OpenRemote before 1.28.0 Cross-Realm Information Disclosure via Notification API

Priority LOW 36CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-200.

Summary

OpenRemote versions before 1.28.0 contain a cross-realm information disclosure vulnerability in the Notification REST API that allows per-realm tenant administrators to read all tenants' sent notifications including message bodies. Attackers with read:admin credentials in one realm can submit a zero-parameter GET request to the notification endpoint to retrieve sensitive notification metadata and message content from all realms.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00392 33rd percentileScored 2026-11-07
Fix Fixed openremote (openremote): 1.28.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
openremoteopenremotebefore 1.28.01.28.0Patch availableCNA
  • openremote Vendoropenremote Affected before 1.28.0 Fixed in 1.28.0 Patch available CNA

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:openremote:openremote:*:*:*:*:*:*:*:*——openremote
  • cpe:2.3:a:openremote:openremote:*:*:*:*:*:*:*:* Versions — — ·openremote

Remediation

  • Fix · CNA openremote (openremote) Fixed in 1.28.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-81679
  2. 2026-10-03 Alias added: GHSA-fgj3-5frq-8vw8

References

  • TI-2022-13714 An issue was discovered in OpenRemote through 1.0.4 allows attackers to execute arbitrary… CVSS 3.1CRITICAL 9.8
  • TI-2026-28724 OpenRemote is Vulnerable to Expression Injection CVSS 3.1CRITICAL 10.0
  • TI-2026-79160 Missing authorization in OpenRemote gateway tunnel endpoints CVSS 4.0CRITICAL 9.0
  • TI-2026-40948 OpenRemote < 1.25.0 IDOR via Bulk Alarm Deletion Endpoint CVSS 4.0HIGH 8.6
  • TI-2026-71893 OpenRemote: Cross-Realm User Information Disclosure in UserResourceImpl CVSS 3.1HIGH 7.7
  • TI-2026-29790 OpenRemote has Improper Access Control via updateUserRealmRoles function CVSS 3.1HIGH 7.0
See all 18 →

Sources