Out-of-bounds write in Vinyl-Cache Vinyl Cache
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
In Vinyl Cache before 9.0,2, workspace buffer overflow vulnerability was found in the .upper() and .lower() string type methods of VCL. This can be used as a remote denial of service (DoS) vector to make the child process segfault or assert, and then restart. Effectively exploiting this vulnerability requires prior knowledge about the VCL in use and the ability to craft a request that contains a string that is long enough to fill the remaining workspace at the call site while staying under the different request size limits (http_req_size, http_req_hdr_len, etc.).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Vinyl-Cache | Vinyl Cache | before 9.0.2 | 9.0.2 | Patch available | CNA |
| varnish-software | Varnish Cache | 9.0.0 to before 9.0.4; 6.3.0 – 8.0.2 | 9.0.4 | Patch available | CNA |
- Vinyl Cache VendorVinyl-Cache Affected before 9.0.2 Fixed in 9.0.2 Patch available CNA
- Varnish Cache Vendorvarnish-software Affected 9.0.0 to before 9.0.4; 6.3.0 – 8.0.2 Fixed in 9.0.4 Patch available CNA
Remediation
- Fix · CNA Vinyl Cache (Vinyl-Cache) Fixed in 9.0.2
- Fix · CNA Varnish Cache (Varnish-Software) Fixed in 9.0.4
Timeline
- 2026-10-02 Threatist record created from CVE-2026-93894
- 2026-10-03 Alias added: GHSA-pfj3-384h-g8q8
References
More Vinyl-Cache vulnerabilities
- TI-2026-26733 Varnish Cache before 8.0.1 and Varnish Enterprise before 6.0.16r12, in certain unchecked… CVSS 3.1CRITICAL 9.8
- TI-2026-29164 Varnish Cache 9 before 9.0.1 allows a "workspace overflow" denial of service (daemon… CVSS 3.1HIGH 7.5
- TI-2026-29162 Varnish Cache 9 before 9.0.1 and Varnish Enterprise before 6.0.16r11 allows a "workspace… CVSS 3.1HIGH 7.5
Sources
- CVE-2026-93894 · CVE Program
- CVE-2026-93894 · NVD
- FIRST EPSS
- GHSA-pfj3-384h-g8q8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences