Tauri framework v2 missing updater signature version number validation can be exploited into forced downgrade
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
The Tauri updater plugin verifies update binaries using minisign signatures, but the signature covers only the raw binary bytes. The update manifest -- which contains the version number, download URL, and signature -- is fetched over TLS but is never itself signed or authenticated. Because the only anti-rollback check compares the manifest's version field against the current version, and that field is unsigned, an attacker who can serve a crafted manifest can force installation of any older signed release without possessing the developer's private key.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tauri-apps | tauri-plugin-updater | 2.0.0 to before 2.12.0; 2.12.0 and later | — | No fix listed | CNA |
- tauri-plugin-updater Vendortauri-apps Affected 2.0.0 to before 2.12.0; 2.12.0 and later Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-95625
- 2026-10-03 Alias added: GHSA-p8c6-29q6-cqw7
References
More tauri-apps vulnerabilities
- TI-2025-22658 Improper Scope Validation in the open Endpoint of tauri-plugin-shell CVSS 4.0CRITICAL 9.3
- TI-2022-18594 The readDir Endpoint Scope can be Bypassed With Symbolic Links in Tauri CVSS 3.1HIGH 8.3
- TI-2023-24757 Updater Private Keys Possibly Leaked via Vite Environment Variables in tauri-cli CVSS 3.1HIGH 8.4
- TI-2022-22815 Tauri vulnerable to path traversal CVSS 3.1HIGH 7.7
- TI-2026-30506 Tauri: Origin Confusion Allows Remote Pages to Invoke Local-Only IPC Commands CVSS 4.0MEDIUM 6.1
- TI-2024-23292 iFrames Bypass Origin Checks for Tauri API Access Control CVSS 3.1MEDIUM 5.9
Sources
- CVE-2026-95625 · CVE Program
- CVE-2026-95625 · NVD
- FIRST EPSS
- GHSA-p8c6-29q6-cqw7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences