Moodle: arbitrary class instantiation via report builder audience classname
Priority LOW 20CWE-470Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
A flaw was found in Moodle. An authenticated attacker can supply an improperly validated audience class name to the Report Builder component, allowing arbitrary class instantiation. This vulnerability enables the unauthorized creation of internal program objects, which may result in unexpected application behavior.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00236 14th percentileScored 2026-11-07
Fix Fixed moodle: 5.2.2, 5.1.6, 5.0.9 +1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | 5.2.0 to before 5.2.2; 5.1.0 to before 5.1.6; 5.0.0 to before 5.0.9; before 4.5.13 | 5.2.2, 5.1.6, 5.0.9, 4.5.13 | Patch available | CNA |
- moodle Vendor— Affected 5.2.0 to before 5.2.2; 5.1.0 to before 5.1.6; 5.0.0 to before 5.0.9; before 4.5.13 Fixed in 5.2.2, 5.1.6, 5.0.9, 4.5.13 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | before 4.5.13; 5.0.0 to before 5.0.9; 5.1.0 to before 5.1.6; 5.2.0 to before 5.2.2 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions before 4.5.13; 5.0.0 to before 5.0.9; 5.1.0 to before 5.1.6; 5.2.0 to before 5.2.2 Vulnerable ·Moodle
Remediation
- Fix · CNA moodle Fixed in 5.2.2, 5.1.6, 5.0.9, 4.5.13
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-102580
- 2026-10-03 Alias added: GHSA-xw58-hp5c-6wc2
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2026-102580 · CVE Program
- CVE-2026-102580 · NVD
- FIRST EPSS
- GHSA-xw58-hp5c-6wc2 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-102580 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences