Read the docs

Moodle: xss in forum post templates due to insufficient escaping

Priority LOW 24CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

A flaw was found in Moodle. Insufficient output escaping in templates used to display forum posts enables a stored cross-site scripting (XSS) vulnerability. An attacker can inject malicious content into a forum post, which then executes arbitrary script code in the browser of another user viewing the affected post.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00198 9th percentileScored 2026-11-07
Fix Fixed moodle: 5.2.2, 5.1.6, 5.0.9 +1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—moodle5.2.0 to before 5.2.2; 5.1.0 to before 5.1.6; 5.0.0 to before 5.0.9; before 4.5.135.2.2, 5.1.6, 5.0.9, 4.5.13Patch availableCNA
  • moodle Vendor— Affected 5.2.0 to before 5.2.2; 5.1.0 to before 5.1.6; 5.0.0 to before 5.0.9; before 4.5.13 Fixed in 5.2.2, 5.1.6, 5.0.9, 4.5.13 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*before 4.5.13; 5.0.0 to before 5.0.9; 5.1.0 to before 5.1.6; 5.2.0 to before 5.2.2VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions before 4.5.13; 5.0.0 to before 5.0.9; 5.1.0 to before 5.1.6; 5.2.0 to before 5.2.2 Vulnerable ·Moodle

Remediation

  • Fix · CNA moodle Fixed in 5.2.2, 5.1.6, 5.0.9, 4.5.13

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-102581
  2. 2026-10-03 Alias added: GHSA-g6pg-29qv-3h3r

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources