Moodle: incorrect capability check in ai generate image web service
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-425.
Summary
A flaw was found in Moodle. An incorrect capability check in the artificial intelligence (AI) editor placement's image generation web service allows an authenticated user to invoke the feature without holding the required capability. This flaw permits unauthorized users to access and utilize the AI image generation functionality.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | 5.2.0 to before 5.2.2; 5.1.0 to before 5.1.6; 5.0.0 to before 5.0.9; before 4.5.13 | 5.2.2, 5.1.6, 5.0.9, 4.5.13 | Patch available | CNA |
- moodle Vendor— Affected 5.2.0 to before 5.2.2; 5.1.0 to before 5.1.6; 5.0.0 to before 5.0.9; before 4.5.13 Fixed in 5.2.2, 5.1.6, 5.0.9, 4.5.13 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | before 4.5.13; 5.0.0 to before 5.0.9; 5.1.0 to before 5.1.6; 5.2.0 to before 5.2.2 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions before 4.5.13; 5.0.0 to before 5.0.9; 5.1.0 to before 5.1.6; 5.2.0 to before 5.2.2 Vulnerable ·Moodle
Remediation
- Fix · CNA moodle Fixed in 5.2.2, 5.1.6, 5.0.9, 4.5.13
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-102583
- 2026-10-03 Alias added: GHSA-57f5-xvgq-p2v3
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2026-102583 · CVE Program
- CVE-2026-102583 · NVD
- FIRST EPSS
- GHSA-57f5-xvgq-p2v3 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-102583 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences