Moodle: xss via password reset link due to insufficient username escaping
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
A flaw was found in Moodle. Insufficient sanitization of username input on the password reset page allows a remote attacker to conduct a cross-site scripting (XSS) attack. By convincing an unauthenticated user to access a specially crafted password reset link, an attacker could execute arbitrary script in the victim's browser.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | 5.2.0 to before 5.2.2; 5.1.0 to before 5.1.6; 5.0.0 to before 5.0.9; before 4.5.13 | 5.2.2, 5.1.6, 5.0.9, 4.5.13 | Patch available | CNA |
- moodle Vendor— Affected 5.2.0 to before 5.2.2; 5.1.0 to before 5.1.6; 5.0.0 to before 5.0.9; before 4.5.13 Fixed in 5.2.2, 5.1.6, 5.0.9, 4.5.13 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | before 4.5.13; 5.0.0 to before 5.0.9; 5.1.0 to before 5.1.6; 5.2.0 to before 5.2.2 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions before 4.5.13; 5.0.0 to before 5.0.9; 5.1.0 to before 5.1.6; 5.2.0 to before 5.2.2 Vulnerable ·Moodle
Remediation
- Fix · CNA moodle Fixed in 5.2.2, 5.1.6, 5.0.9, 4.5.13
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-102586
- 2026-10-03 Alias added: GHSA-rfv4-mv3r-qx66
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2026-102586 · CVE Program
- CVE-2026-102586 · NVD
- FIRST EPSS
- GHSA-rfv4-mv3r-qx66 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-102586 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences