OpenAM before 16.1.3 Reflected XSS via OAuth2 Authorization Error Page
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
OpenAM before 16.1.3 contains a reflected cross-site scripting vulnerability that allows unauthenticated attackers to inject script by supplying crafted parameters rendered unencoded on the OAuth2 authorization error page. Attackers can lure victims to a crafted /oauth2/authorize link with repeated parameters to run JavaScript in the OpenAM origin, acting within existing sessions or redirecting to phishing pages.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| OpenIdentityPlatform | OpenAM | before 16.1.3 | 16.1.3 | Patch available | CNA |
- OpenAM VendorOpenIdentityPlatform Affected before 16.1.3 Fixed in 16.1.3 Patch available CNA
Remediation
- Fix · CNA OpenAM (OpenIdentityPlatform) Fixed in 16.1.3
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
OpenIdentityPlatform OpenAM 16.1.3
9 records Highest priority Priority MEDIUM 1 MEDIUM, 8 LOW
Other records, highest priority first
- TI-2026-67490 OpenAM before 16.1.3 Unauthenticated Arbitrary Class Instantiation via JAX-RPC InterfacePriority MEDIUM 44
- TI-2026-67494 OpenAM before 16.1.3 PKCE Enforcement Bypass via OAuth 2.0 Hybrid FlowsPriority LOW 35
- TI-2026-67496 OpenAM before 16.1.3 Improper Authorization in Delegated Session-Destroy Realm ScopingPriority LOW 30
Timeline
- 2026-10-03 Threatist record created from CVE-2026-105114
- 2026-10-03 Alias added: GHSA-875h-jw66-233j
- 2026-10-06 CISA SSVC decision points changed
References
More OpenIdentityPlatform vulnerabilities
- TI-2025-20332 OpenDJ Denial of Service (Dos) using alias loop CVSS 4.0HIGH 8.7
- TI-2026-25836 Pre-Authentication Remote Code Execution via `jato.clientSession` Deserialization in OpenAM CVSS 4.0CRITICAL 9.3
- TI-2026-44519 OpenAM: Unauthenticated Remote Code Execution via Class.forName in AuthXMLUtils.createCustomCallback CVSS 3.1CRITICAL 9.8
- TI-2023-19079 User impersonation using SAMLv1.x SSO in Open Access Management CVSS 3.1CRITICAL 9.8
- TI-2026-34275 OpenAM Authentication Bypass via MSISDN LDAP Injection CVSS 4.0CRITICAL 9.3
- TI-2026-32901 OpenAM Pre-auth User Profile Tampering via Anonymous SOAP Authn in Liberty IDPP/Discovery Endpoints CVSS 4.0CRITICAL 9.3
Sources
- CVE-2026-105114 · CVE Program
- CVE-2026-105114 · NVD
- FIRST EPSS
- GHSA-875h-jw66-233j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences