Request ID reuse lets vLLM scoring mix queries between requests
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · Low
- Fix status
- Partial Red Hat: 3 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-639.
Summary
vLLM versions before 0.30.0 use the caller-controlled X-Request-Id header to key cached query embeddings in flash late-interaction scoring at the /score and /rerank endpoints. A concurrent request that reuses another request's identifier can overwrite the cached query embedding (CWE-639), so the victim's documents are scored against the attacker's query. A remote attacker with low privileges can also trigger a late-interaction cache-miss error through shared use counters.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
vLLM is an inference and serving engine for large language models. Prior to 0.30.0, flash late-interaction scoring at the /score and /rerank endpoints derives each worker's query_key value from the caller-controlled X-Request-Id header. A concurrent request that reuses a victim's identifier can overwrite the cached query embedding so the victim's documents are scored against the attacker's query, and shared use counters can also cause a late-interaction cache-miss error. This issue is fixed in version 0.30.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vllm-project | vllm | before 030.0 | 030.0 | Patch available | CNA |
| — | vllm (PyPI) | before 0.30.0 | 0.30.0 | Patch available | GHSA-2phq-3phc-84px |
- vllm Vendorvllm-project Affected before 030.0 Fixed in 030.0 Patch available CNA
- vllm (PyPI) Vendor— Affected before 0.30.0 Fixed in 0.30.0 Patch available GHSA-2phq-3phc-84px
Remediation
Upgrade the vllm PyPI package to 0.30.0, which fixes the issue. Red Hat AI Inference Server, Red Hat Enterprise Linux AI (RHEL AI) 3 and Red Hat OpenShift AI (RHOAI) are affected. The sources list no fixed version for them.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA vllm (vllm-project) Fixed in 030.0
- Fix · GHSA-2phq-3phc-84px vllm (PyPI) Fixed in 0.30.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat AI Inference Server | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux AI (RHEL AI) 3 | Affected | No fix yet: Fix deferred |
| Red Hat OpenShift AI (RHOAI) | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-06 Threatist record created from CVE-2026-105755
- 2026-10-06 Alias added: GHSA-2phq-3phc-84px
- 2026-10-06 Fix available: PyPI/[email protected] · GHSA-2phq-3phc-84px
- 2026-10-06 CVSS score added · GHSA-2phq-3phc-84px
- 2026-10-06 Weakness changed · GHSA-2phq-3phc-84px
- 2026-10-06 5 new references · GHSA-2phq-3phc-84px
- 2026-10-06 Affected versions changed · Red Hat
- 2026-10-06 CVSS score added · Red Hat
- 2026-10-06 CISA SSVC decision points changed
References
Patch 2
More vllm-project vulnerabilities
- TI-2024-10229 Remote Code Execution in vllm-project/vllm CVSS 3.0CRITICAL 9.8
- TI-2024-08404 Remote Code Execution in vllm-project/vllm CVSS 3.1CRITICAL 9.8
- TI-2026-36017 vLLM: OpenAI auth bypass CVSS 3.1CRITICAL 9.1
- TI-2026-63056 vLLM before 0.28.0 Denial of Service via negative token ID CVSS 4.0HIGH 8.7
- TI-2026-04308 Hardcoded trust_remote_code=True in vllm-project/vllm Bypasses User Security Control CVSS 3.0HIGH 8.8
- TI-2026-39137 vLLM: Remote DoS in vLLM via Invalid Recovered Token Reinjection CVSS 3.1HIGH 7.5
Sources
- CVE-2026-105755 · CVE Program
- CVE-2026-105755 · NVD
- FIRST EPSS
- GHSA-2phq-3phc-84px · GitHub Advisory Database · CC BY 4.0
- CVE-2026-105755 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences