vLLM GLMGA video sampling lets requests exhaust CPU and memory
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Partial Red Hat: 3 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-400.
Summary
vLLM versions from 0.23.0rc2 before 0.30.0 are affected. The GLMGA video backend builds and deduplicates a frame-index list sized by request-level fps and max_frames values, with no strict work ceiling (CWE-400). A remote caller without privileges can send a compact request with a tiny valid video to consume excessive CPU and memory in the shared media-loading executor, which degrades availability.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
vLLM is an inference and serving engine for large language models. Prior to 0.30.0, a caller can use the request-level media_io_kwargs field to select the GLMGA video backend and supply large values for the fps and max_frames options without a strict work ceiling. GLMGA constructs and deduplicates an attacker-sized pre-decode frame-index list, allowing a compact request and tiny valid video to consume disproportionate CPU time and memory in the shared media-loading executor. This issue is fixed in version 0.30.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vllm-project | vllm | 0.23.0rc2 to before 0.30.0 | 0.30.0 | Patch available | CNA |
| — | vllm (PyPI) | 0.23.0rc2 to before 0.30.0 | 0.30.0 | Patch available | GHSA-58v5-2m8f-94pr |
- vllm Vendorvllm-project Affected 0.23.0rc2 to before 0.30.0 Fixed in 0.30.0 Patch available CNA
- vllm (PyPI) Vendor— Affected 0.23.0rc2 to before 0.30.0 Fixed in 0.30.0 Patch available GHSA-58v5-2m8f-94pr
Remediation
Upgrade vLLM to version 0.30.0, which fixes this issue. Red Hat AI Inference Server, Red Hat Enterprise Linux AI (RHEL AI) 3 and Red Hat OpenShift AI (RHOAI) are affected, and Red Hat lists no available plan for them.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA vllm (vllm-project) Fixed in 0.30.0
- Fix · GHSA-58v5-2m8f-94pr vllm (PyPI) Fixed in 0.30.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat AI Inference Server | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux AI (RHEL AI) 3 | Affected | No fix yet: Fix deferred |
| Red Hat OpenShift AI (RHOAI) | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-06 Threatist record created from CVE-2026-105760
- 2026-10-06 Alias added: GHSA-58v5-2m8f-94pr
- 2026-10-06 Fix available: PyPI/[email protected] · GHSA-58v5-2m8f-94pr
- 2026-10-06 CVSS score added · GHSA-58v5-2m8f-94pr
- 2026-10-06 Weakness changed · GHSA-58v5-2m8f-94pr
- 2026-10-06 5 new references · GHSA-58v5-2m8f-94pr
- 2026-10-06 Affected versions changed · Red Hat
- 2026-10-06 CVSS score added · Red Hat
- 2026-10-06 CISA SSVC decision points changed
References
Patch 2
More vllm-project vulnerabilities
- TI-2024-10229 Remote Code Execution in vllm-project/vllm CVSS 3.0CRITICAL 9.8
- TI-2024-08404 Remote Code Execution in vllm-project/vllm CVSS 3.1CRITICAL 9.8
- TI-2026-36017 vLLM: OpenAI auth bypass CVSS 3.1CRITICAL 9.1
- TI-2026-63056 vLLM before 0.28.0 Denial of Service via negative token ID CVSS 4.0HIGH 8.7
- TI-2026-04308 Hardcoded trust_remote_code=True in vllm-project/vllm Bypasses User Security Control CVSS 3.0HIGH 8.8
- TI-2026-39137 vLLM: Remote DoS in vLLM via Invalid Recovered Token Reinjection CVSS 3.1HIGH 7.5
Sources
- CVE-2026-105760 · CVE Program
- CVE-2026-105760 · NVD
- FIRST EPSS
- GHSA-58v5-2m8f-94pr · GitHub Advisory Database · CC BY 4.0
- CVE-2026-105760 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences