Read the docs
TI-2026-69715 Aliases CVE-2026-107322

OS command injection in Amazon Agent Plugins for AWS databases-on-aws

Priority LOW 38CWE-184Published · Updated

Key facts

Attack vector
Local
Privileges required
None
User interaction
Passive
Attack complexity
Low
Attack requirements
None
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA.

Summary

CWE-184 (Incomplete List of Disallowed Inputs) in the Amazon Agent Plugins for AWS databases-on-aws plugin before 1.7.1 may allow a remote unauthenticated actor to run arbitrary operating system commands on the host running the helper. The actor does this with a crafted database command value introduced in the agent context. The CVSS 4.0 base score is 8.5 (HIGH).

Written with Claude Haiku 5.5 from the sources below · 2026-10-29

Description from the CNA

An incomplete list of disallowed inputs in Amazon Agent Plugins for AWS databases-on-aws plugin before 1.7.1 might allow a remote unauthenticated actor to execute arbitrary operating system commands on the host running the helper via a crafted database command value introduced in the agent context. To remediate this issue, users should upgrade to databases-on-aws plugin version 1.7.1 or later and verify that the updated plugin is active in each environment where it is used.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00126 2nd percentileScored 2026-11-07
Fix Fixed databases-on-aws (aws): 1.7.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
AWSdatabases-on-awsbefore 1.7.11.7.1Patch availableCNA
  • databases-on-aws VendorAWS Affected before 1.7.1 Fixed in 1.7.1 Patch available CNA

Remediation

Upgrade the databases-on-aws plugin to version 1.7.1 or later, then verify that the updated plugin is active in each environment where it is used.

Written with Claude Haiku 5.5 from the sources below · 2026-10-29

  • Fix · CNA databases-on-aws (aws) Fixed in 1.7.1

Timeline

  1. 2026-10-09 Threatist record created from CVE-2026-107322

References

  • TI-2026-23989 crypto: algif_aead - Revert to operating out-of-place KEVCVSS 3.1HIGH 7.8
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2024-18648 Amazon AWS Amplify CLI before 12.10.1 incorrectly configures the role trust policy of IAM… CVSS 3.1CRITICAL 9.8
  • TI-2024-05929 Openssh: regresshion - race condition in ssh allows rce/dos CVSS 3.1HIGH 8.1
  • TI-2025-03847 Input validation issue in AWS Amplify Studio UI component properties CVSS 4.0CRITICAL 9.0
  • TI-2026-11603 HTTP/2 Stream Parser Confusion Body-Inspection Bypass in Amazon CloudFront with AWS WAF CVSS 4.0HIGH 7.9
See all 383 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences