AWS Amplify query resolvers let users read other users' records
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-639.
Summary
The query resolvers generated by @aws-amplify/graphql-index-transformer in the AWS Amplify API Category, from 2.2.0 before 3.1.2, have an authorization flaw (CWE-639) that lets requests reach records they should not. An authenticated remote user can read records owned by other users of the same application through crafted queries.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
Description from the CNA
Improper authorization in the query resolvers generated by @aws-amplify/graphql-index-transformer in AWS Amplify API Category before 3.1.2 might allow an authenticated remote user to read records owned by other users of the same application via crafted queries. This issue has been addressed in @aws-amplify/graphql-index-transformer 3.1.2 https://www.npmjs.com/package/@aws-amplify/graphql-index-transformer/v/3.1.2 (included in @aws-amplify/data-construct 1.17.4 https://www.npmjs.com/package/@aws-amplify/data-construct/v/1.17.4 and @aws-amplify/graphql-api-construct 1.21.4 https://www.npmjs.com/package/@aws-amplify/graphql-api-construct/v/1.21.4 ). We recommend upgrading to the latest version ensuring any forked or derivative code is patched to incorporate the new fixes and then redeploying their backend.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| AWS | aws-amplify/graphql-index-transformer | 2.2.0 to before 3.1.2 | 3.1.2 | Patch available | CNA |
| AWS | aws-amplify/graphql-api-construct | 1.4.0 to before 1.21.4 | 1.21.4 | Patch available | CNA |
| AWS | aws-amplify/data-construct | before 1.17.4 | 1.17.4 | Patch available | CNA |
- aws-amplify/graphql-index-transformer VendorAWS Affected 2.2.0 to before 3.1.2 Fixed in 3.1.2 Patch available CNA
- aws-amplify/graphql-api-construct VendorAWS Affected 1.4.0 to before 1.21.4 Fixed in 1.21.4 Patch available CNA
- aws-amplify/data-construct VendorAWS Affected before 1.17.4 Fixed in 1.17.4 Patch available CNA
Remediation
Upgrade @aws-amplify/graphql-index-transformer to 3.1.2, @aws-amplify/graphql-api-construct to 1.21.4 and @aws-amplify/data-construct to 1.17.4, ensure any forked or derivative code includes the fix, and then redeploy the backend.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
- Fix · CNA aws-amplify/graphql-index-transformer (AWS) Fixed in 3.1.2
- Fix · CNA aws-amplify/graphql-api-construct (AWS) Fixed in 1.21.4
- Fix · CNA aws-amplify/data-construct (AWS) Fixed in 1.17.4
Vendor assessments
Timeline
- 2026-10-10 Threatist record created from CVE-2026-108096
- 2026-10-11 Priority changed: MEDIUM → LOW
- 2026-10-16 CISA SSVC decision points changed
- 2026-10-20 Fix available: AWS/aws-amplify/[email protected] · CNA
- 2026-11-06 Affected versions changed · Red Hat
- 2026-11-06 CVSS score added · Red Hat
References
Patch 3
More AWS vulnerabilities
- TI-2026-23989 crypto: algif_aead - Revert to operating out-of-place KEVCVSS 3.1HIGH 7.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-18648 Amazon AWS Amplify CLI before 12.10.1 incorrectly configures the role trust policy of IAM… CVSS 3.1CRITICAL 9.8
- TI-2024-05929 Openssh: regresshion - race condition in ssh allows rce/dos CVSS 3.1HIGH 8.1
- TI-2025-03847 Input validation issue in AWS Amplify Studio UI component properties CVSS 4.0CRITICAL 9.0
- TI-2026-11603 HTTP/2 Stream Parser Confusion Body-Inspection Bypass in Amazon CloudFront with AWS WAF CVSS 4.0HIGH 7.9
Sources
- CVE-2026-108096 · CVE Program
- CVE-2026-108096 · NVD
- FIRST EPSS
- CVE-2026-108096 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences