Read the docs

Heap overflow in vLLM audio transcription crashes the API process

Priority MEDIUM 64CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Partial Red Hat: 3 without a fix

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and Red Hat.

Summary

vLLM before 0.29.0 passes uploaded audio to an FFmpeg fallback that checks only the file size. Improper input validation (CWE-20) lets malformed IAMF containers trigger a heap overflow in FFmpeg's IAMF parser. An authenticated remote attacker with low privileges can repeatedly upload such files to the audio transcriptions endpoint, crashing the API process. CISA SSVC assessment reports proof of concept exploitation.

Written with Claude Haiku 5.5 from the sources below · 2026-10-29

Description from the CNA

vLLM before 0.29.0 passes uploaded audio to the PyAV/FFmpeg av.open() fallback with only a file-size check, exposing FFmpeg's IAMF parser heap overflow. Authenticated remote attackers can repeatedly upload malformed IAMF containers to /v1/audio/transcriptions, corrupting the heap and crashing the API process.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00479 41st percentileScored 2026-11-07
Fix Partial vllm (vllm-project): 0.29.0Red Hat: 3 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
vllm-projectvllmbefore 0.29.00.29.0Patch availableCNA
  • vllm Vendorvllm-project Affected before 0.29.0 Fixed in 0.29.0 Patch available CNA

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:vllm:vllm:*:*:*:*:*:*:*:*——vLLM
  • cpe:2.3:a:vllm:vllm:*:*:*:*:*:*:*:* Versions — — ·vLLM

Remediation

Upgrade vllm to version 0.29.0, which fixes the flaw. Red Hat lists no available fix for Red Hat AI Inference Server, Red Hat Enterprise Linux AI (RHEL AI) 3 and Red Hat OpenShift AI (RHOAI).

Written with Claude Haiku 5.5 from the sources below · 2026-10-29

  • Fix · CNA vllm (vllm-project) Fixed in 0.29.0

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat AI Inference ServerAffectedNo fix yet: Fix deferred
Red Hat Enterprise Linux AI (RHEL AI) 3AffectedNo fix yet: Fix deferred
Red Hat OpenShift AI (RHOAI)AffectedNo fix yet: Fix deferred

Timeline

  1. 2026-10-12 Threatist record created from CVE-2026-109311
  2. 2026-10-12 Alias added: GHSA-8wc5-pcgr-pg48
  3. 2026-10-13 Priority changed: MEDIUM → LOW
  4. 2026-10-18 CISA SSVC decision points changed
  5. 2026-10-18 Priority changed: LOW → MEDIUM
  6. 2026-10-18 Affected versions changed · Red Hat
  7. 2026-10-18 CVSS score added · Red Hat

References

  • TI-2024-10229 Remote Code Execution in vllm-project/vllm CVSS 3.0CRITICAL 9.8
  • TI-2024-08404 Remote Code Execution in vllm-project/vllm CVSS 3.1CRITICAL 9.8
  • TI-2026-36017 vLLM: OpenAI auth bypass CVSS 3.1CRITICAL 9.1
  • TI-2026-63056 vLLM before 0.28.0 Denial of Service via negative token ID CVSS 4.0HIGH 8.7
  • TI-2026-04308 Hardcoded trust_remote_code=True in vllm-project/vllm Bypasses User Security Control CVSS 3.0HIGH 8.8
  • TI-2026-39137 vLLM: Remote DoS in vLLM via Invalid Recovered Token Reinjection CVSS 3.1HIGH 7.5
See all 124 →

Sources