Grav API Plugin Privilege Escalation via Scalar Access Grants
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-269.
Summary
The Grav API plugin (grav-plugin-api) before 1.0.36 lets delegated user managers gain super-admin access by storing positive scalar admin or api parent grants. An attacker with api.users.write can edit account access maps or invitations so the inheriting permission resolver satisfies requireSuper checks, which opens super-only API endpoints. The weakness is classified as CWE-269, Improper Privilege Management, with a CVSS 4.0 base score of 8.6 (HIGH).
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
Grav grav-plugin-api before 1.0.36 contains a privilege escalation vulnerability that allows delegated user managers to obtain super-admin access by storing positive scalar admin or api parent grants. Attackers with api.users.write can edit account access maps or invitations so the inheriting permission resolver satisfies requireSuper checks, accessing super-only API endpoints.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Update grav-plugin-api to version 1.0.36 or later, the release that fixes this issue.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA grav-plugin-api (getgrav) Fixed in 1.0.36
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
getgrav grav-plugin-api 1.0.36
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2026-71136 Disabled Grav accounts keep API access through existing sessionsPriority LOW 24
Timeline
- 2026-10-12 Threatist record created from CVE-2026-109317
- 2026-10-12 Alias added: GHSA-7ghm-8q85-6h4j
- 2026-10-13 Priority changed: MEDIUM → LOW
- 2026-10-15 CISA SSVC decision points changed
References
More getgrav vulnerabilities
- TI-2026-30893 Grav: Privilege Escalation via Missing Server-Side Validation of groups/access CVSS 3.1CRITICAL 9.4
- TI-2025-28971 Cross Site Scripting vulnerability in grav v.1.7.48 and before allows an attacker to… CVSS 3.1CRITICAL 9.8
- TI-2021-04523 Unauthenticated Arbitrary YAML Write/Update leads to Code Execution CVSS 3.1CRITICAL 9.8
- TI-2026-50940 Grav CMS before 2.0.16 Origin Validation Bypass via Referer CVSS 4.0CRITICAL 9.3
- TI-2026-46446 Grav before 2.0.7 Remote Code Execution via Blueprint dynamicData CVSS 4.0CRITICAL 9.3
- TI-2021-22428 GravCMS 1.10.7 - Arbitrary YAML Write/Update (Unauthenticated) (2) CVSS 4.0CRITICAL 9.3
Sources
- CVE-2026-109317 · CVE Program
- CVE-2026-109317 · NVD
- FIRST EPSS
- GHSA-7ghm-8q85-6h4j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences