Read the docs

Disabled Grav accounts keep API access through existing sessions

Priority LOW 24CWE-613Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Security bypass
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-613.

Summary

The Grav API plugin (grav-plugin-api) before 1.0.36 has an improper session validation flaw that lets disabled accounts keep API access. SessionAuthenticator does not enforce account state, so disabled users can reuse an already authorized browser or remember-me session to call API endpoints until it expires. A disabled user with an existing session can exploit it over the network, defeating operator revocation. The weakness is classified as CWE-613.

Written with Claude Haiku 5.5 from the sources below · 2026-10-29

Description from the CNA

The Grav API plugin (grav-plugin-api) before 1.0.36 contains an improper session validation vulnerability that allows disabled accounts to keep API access, because SessionAuthenticator does not enforce account state. Disabled users can reuse an already authorized browser or remember-me session to call API endpoints until expiry, defeating operator revocation.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00245 15th percentileScored 2026-11-07
Fix Fixed grav-plugin-api (getgrav): 1.0.36

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
getgravgrav-plugin-apibefore 1.0.361.0.36Patch availableCNA
  • grav-plugin-api Vendorgetgrav Affected before 1.0.36 Fixed in 1.0.36 Patch available CNA

Remediation

Update the Grav API plugin to version 1.0.36.

Written with Claude Haiku 5.5 from the sources below · 2026-10-29

  • Fix · CNA grav-plugin-api (getgrav) Fixed in 1.0.36

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    getgrav grav-plugin-api 1.0.36

    2 records Highest priority Priority LOW 2 LOW

    Other records, highest priority first

    • TI-2026-71133 Grav API Plugin Privilege Escalation via Scalar Access GrantsPriority LOW 39

Timeline

  1. 2026-10-12 Threatist record created from CVE-2026-109320
  2. 2026-10-12 Alias added: GHSA-wcc2-xcpr-vc5h
  3. 2026-10-13 CISA SSVC decision points changed

References

  • TI-2026-30893 Grav: Privilege Escalation via Missing Server-Side Validation of groups/access CVSS 3.1CRITICAL 9.4
  • TI-2025-28971 Cross Site Scripting vulnerability in grav v.1.7.48 and before allows an attacker to… CVSS 3.1CRITICAL 9.8
  • TI-2021-04523 Unauthenticated Arbitrary YAML Write/Update leads to Code Execution CVSS 3.1CRITICAL 9.8
  • TI-2026-50940 Grav CMS before 2.0.16 Origin Validation Bypass via Referer CVSS 4.0CRITICAL 9.3
  • TI-2026-46446 Grav before 2.0.7 Remote Code Execution via Blueprint dynamicData CVSS 4.0CRITICAL 9.3
  • TI-2021-22428 GravCMS 1.10.7 - Arbitrary YAML Write/Update (Unauthenticated) (2) CVSS 4.0CRITICAL 9.3
See all 228 →

Sources