Missing authorization in Directorist lets subscribers delete listings
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
The Directorist: AI-Powered Business Directory, Listings & Classified Ads plugin for WordPress by wpwax is affected in all versions up to and including 8.10.2.1. The plugin does not verify that a user is authorized to perform an action (CWE-862). An authenticated attacker with subscriber-level access or above can delete arbitrary listings, including those owned by other users and posts in publish, draft, or private status.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
The Directorist: AI-Powered Business Directory, Listings & Classified Ads plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 8.10.2.1. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with subscriber-level access and above, to delete arbitrary business directory listings, including those owned by other users and posts in publish, draft, or private status. The nonces guarding the endpoint do not constitute an authorization barrier because both directorist_nonce and atbdp_nonce_js are exposed to all logged-in users via wp_localize_script.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
The sources list no fixed version for Directorist: AI-Powered Business Directory, Listings & Classified Ads.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Timeline
- 2026-10-14 Threatist record created from CVE-2026-17092
- 2026-10-14 Alias added: GHSA-g592-rv25-8rjh
- 2026-10-14 Priority changed: MEDIUM → LOW
- 2026-10-15 CISA SSVC decision points changed
References
Other 14
- https://www.wordfence.com/threat-intel/vulnerabilities/id/bd520915-2605-450a-9abd-423f1c226eb6?source=cve
- https://plugins.trac.wordpress.org/browser/directorist/tags/8.8.7/includes/classes/class-ajax-handler.php#L1260
- https://plugins.trac.wordpress.org/browser/directorist/tags/8.8.7/includes/classes/class-ajax-handler.php#L1256
- https://plugins.trac.wordpress.org/browser/directorist/tags/8.8.7/includes/classes/class-ajax-handler.php#L24
- https://plugins.trac.wordpress.org/browser/directorist/tags/8.8.7/includes/classes/class-listing-db.php#L101
- https://plugins.trac.wordpress.org/browser/directorist/tags/8.8.7/includes/classes/class-roles.php#L142
- https://plugins.trac.wordpress.org/browser/directorist/tags/8.8.7/includes/asset-loader/localized_data.php#L92
- https://plugins.trac.wordpress.org/browser/directorist/tags/8.7.3/includes/classes/class-ajax-handler.php#L1260
- https://plugins.trac.wordpress.org/browser/directorist/tags/8.7.3/includes/classes/class-ajax-handler.php#L1256
- https://plugins.trac.wordpress.org/browser/directorist/tags/8.7.3/includes/classes/class-ajax-handler.php#L24
- https://plugins.trac.wordpress.org/browser/directorist/tags/8.7.3/includes/classes/class-listing-db.php#L101
- https://plugins.trac.wordpress.org/browser/directorist/tags/8.7.3/includes/classes/class-roles.php#L142
- https://plugins.trac.wordpress.org/browser/directorist/tags/8.7.3/includes/asset-loader/localized_data.php#L92
- https://plugins.trac.wordpress.org/changeset?reponame=&old=3730035%40directorist&new=3730035%40directorist
More wpWax vulnerabilities
- TI-2022-03630 Directorist < 7.4.4 - Subscriber+ Sensitive Information Disclosure CVSS 3.1MEDIUM 6.5
- TI-2022-03605 Directorist < 7.4.2.2 - Subscriber+ Arbitrary User Password Update via IDOR CVSS 3.1MEDIUM 6.5
- TI-2026-42481 WordPress Directorist plugin <= 8.8.2 - PHP Object Injection vulnerability CVSS 3.1CRITICAL 9.8
- TI-2025-23723 WordPress HelpGent plugin <= 2.2.5 - PHP Object Injection vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-01866 Deserialization of untrusted data in wpWax Post Grid, Slider & Carousel Ultimate – with… CVSS 3.1HIGH 8.8
- TI-2026-02713 FormGent <= 1.9.2- Missing Authorization to Unauthenticated Arbitrary File Deletion via 'file_token' Parameter CVSS 3.1CRITICAL 9.1
Sources
- CVE-2026-17092 · CVE Program
- CVE-2026-17092 · NVD
- FIRST EPSS
- GHSA-g592-rv25-8rjh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences