Local file inclusion in ShopMagic plugin lets attackers run PHP files
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-98.
Summary
The ShopMagic email automation for WordPress plugin by wpdesk is affected in all versions through 4.9.0. The billing_address.first_name parameter does not properly control the filename used in PHP include statements (CWE-98), which enables local file inclusion. An unauthenticated remote attacker can include and execute arbitrary .php files on the server, which can bypass access controls, expose sensitive data, or lead to code execution.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
The ShopMagic – email automation for WordPress plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 4.9.0 via the 'billing_address.first_name' parameter parameter. This makes it possible for unauthenticated attackers to include and execute arbitrary .php files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where .php file types can be uploaded and included. Exploitation requires a published recipe that processes the {{ customer.first_name }} placeholder — the plugin's built-in "New Order email with social media profile links" recipe satisfies this requirement out of the box, making the default configuration exploitable with no account, cookie, or nonce by simply submitting a guest checkout with the payload as the billing first name.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
The sources list no fixed version for ShopMagic email automation for WordPress.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Timeline
- 2026-10-14 Threatist record created from CVE-2026-103367
- 2026-10-14 Alias added: GHSA-fqgv-5m94-gg38
- 2026-10-14 CISA SSVC decision points changed
- 2026-10-14 Priority changed: MEDIUM → LOW
References
Other 7
- https://www.wordfence.com/threat-intel/vulnerabilities/id/56c9fe56-8b15-409f-815b-10ee93f5153a?source=cve
- https://plugins.trac.wordpress.org/browser/shopmagic-for-woocommerce/tags/4.9.0/vendor_prefixed/wpdesk/wp-view/src/Renderer/SimplePhpRenderer.php#L47
- https://plugins.trac.wordpress.org/browser/shopmagic-for-woocommerce/tags/4.9.0/src/Workflow/Placeholder/Builtin/Order/OrderProductsOrdered.php#L58
- https://plugins.trac.wordpress.org/browser/shopmagic-for-woocommerce/tags/4.9.0/src/Workflow/Placeholder/PlaceholderProcessor.php#L47
- https://plugins.trac.wordpress.org/browser/shopmagic-for-woocommerce/tags/4.9.0/src/Workflow/Placeholder/Builtin/Customer/CustomerFirstName.php#L19
- https://plugins.trac.wordpress.org/browser/shopmagic-for-woocommerce/tags/4.9.0/src/Customer/Guest/GuestFactory.php#L34
- https://plugins.trac.wordpress.org/browser/shopmagic-for-woocommerce/tags/4.9.1
More wpdesk vulnerabilities
- TI-2026-51484 WordPress Flexible Subscriptions plugin <= 1.8.1 - PHP Object Injection vulnerability CVSS 3.1CRITICAL 9.8
- TI-2020-18902 Flexible Checkout Fields for WooCommerce <= 2.3.1 - Unauthenticated Arbitrary Plugin Settings Update CVSS 3.1HIGH 7.2
- TI-2026-83314 Sensitive data exposure in WordPress Flexible Chat plugin CVSS 3.1HIGH 7.5
- TI-2024-20643 WordPress Flexible Checkout Fields for WooCommerce plugin <= 4.1.2 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2024-12735 Flexible Wishlist for WooCommerce <= 1.2.25 - Unauthenticated Stored Cross-Site Scripting via wishlist_name Parameter CVSS 3.1HIGH 7.2
- TI-2026-41362 WordPress Autopay dla WooCommerce plugin <= 2.2.27 - Broken Access Control vulnerability CVSS 3.1MEDIUM 6.5
Sources
- CVE-2026-103367 · CVE Program
- CVE-2026-103367 · NVD
- FIRST EPSS
- GHSA-fqgv-5m94-gg38 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences