Read the docs

Symfony YAML Inline Lexer Unbounded Recursion Crashes the Process

Priority MEDIUM 44CWE-674Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-674.

Summary

Symfony packages symfony/symfony and symfony/yaml before 5.4.54, from 6.0.0-BETA1 before 6.4.45, from 7.0.0-BETA1 before 7.4.18, and from 8.0.0-BETA1 before 8.1.6 are affected. Yaml\Parser recurses through nested { and [ collections without enforcing the nesting limit (CWE-674). A single unauthenticated request with deeply nested inline YAML exhausts the stack, crashing the process or ending it with a fatal error.

Written with Claude Haiku 5.5 from the sources below · 2026-11-06

Description from the CNA

In Symfony YAML prior to versions 5.4.54, 6.4.45, 7.4.18, and 8.1.6, Yaml\Parser::lexInlineStructure() recursed through lexInlineMapping() and lexInlineSequence() for every { and [ of an inline collection, without entering the nesting level that the rest of the parser bounds with maxNestingLevel. A document made of deeply nested inline collections, such as [[[[...]]]], exhausted the stack while it was being lexed: depending on the PHP version and its stack settings, the process crashed or the request ended with a fatal error. Any code parsing untrusted YAML is affected. That includes #[MapRequestPayload] when the Yaml component is installed and the endpoint does not restrict acceptFormat: a single unauthenticated request with a YAML content type is enough. This issue affects symfony/yaml through v5.4.53, v6.0.0-BETA1 through v6.4.44, v7.0.0-BETA1 through v7.4.17, and v8.0.0-BETA1 through v8.1.5.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00395 33rd percentileScored 2026-11-07
Fix Fixed symfony/symfony (Packagist): 5.4.54, 6.4.45, 7.4.18 +1symfony/yaml (Packagist): 5.4.54, 6.4.45, 7.4.18 +1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—symfony/symfony (Packagist)2.0.0 to before 5.4.545.4.54Patch availableGHSA-2v3c-qxhr-7vpv
—symfony/symfony (Packagist)6.0.0 to before 6.4.456.4.45Patch availableGHSA-2v3c-qxhr-7vpv
—symfony/symfony (Packagist)7.0.0 to before 7.4.187.4.18Patch availableGHSA-2v3c-qxhr-7vpv
—symfony/symfony (Packagist)8.0.0 to before 8.1.68.1.6Patch availableGHSA-2v3c-qxhr-7vpv
—symfony/yaml (Packagist)2.0.0 to before 5.4.545.4.54Patch availableGHSA-2v3c-qxhr-7vpv
—symfony/yaml (Packagist)6.0.0 to before 6.4.456.4.45Patch availableGHSA-2v3c-qxhr-7vpv
—symfony/yaml (Packagist)7.0.0 to before 7.4.187.4.18Patch availableGHSA-2v3c-qxhr-7vpv
—symfony/yaml (Packagist)8.0.0 to before 8.1.68.1.6Patch availableGHSA-2v3c-qxhr-7vpv
  • symfony/symfony (Packagist) Vendor— Affected 2.0.0 to before 5.4.54 Fixed in 5.4.54 Patch available GHSA-2v3c-qxhr-7vpv
  • symfony/symfony (Packagist) Vendor— Affected 6.0.0 to before 6.4.45 Fixed in 6.4.45 Patch available GHSA-2v3c-qxhr-7vpv
  • symfony/symfony (Packagist) Vendor— Affected 7.0.0 to before 7.4.18 Fixed in 7.4.18 Patch available GHSA-2v3c-qxhr-7vpv
  • symfony/symfony (Packagist) Vendor— Affected 8.0.0 to before 8.1.6 Fixed in 8.1.6 Patch available GHSA-2v3c-qxhr-7vpv
  • symfony/yaml (Packagist) Vendor— Affected 2.0.0 to before 5.4.54 Fixed in 5.4.54 Patch available GHSA-2v3c-qxhr-7vpv
  • symfony/yaml (Packagist) Vendor— Affected 6.0.0 to before 6.4.45 Fixed in 6.4.45 Patch available GHSA-2v3c-qxhr-7vpv
  • symfony/yaml (Packagist) Vendor— Affected 7.0.0 to before 7.4.18 Fixed in 7.4.18 Patch available GHSA-2v3c-qxhr-7vpv
  • symfony/yaml (Packagist) Vendor— Affected 8.0.0 to before 8.1.6 Fixed in 8.1.6 Patch available GHSA-2v3c-qxhr-7vpv

Remediation

Fixed versions are 5.4.54, 6.4.45, 7.4.18 and 8.1.6 for both symfony/symfony and symfony/yaml.

Written with Claude Haiku 5.5 from the sources below · 2026-11-06

  • Fix · GHSA-2v3c-qxhr-7vpv symfony/symfony (Packagist) Fixed in 5.4.54 Advisory →
  • Fix · GHSA-2v3c-qxhr-7vpv symfony/symfony (Packagist) Fixed in 6.4.45 Advisory →
  • Fix · GHSA-2v3c-qxhr-7vpv symfony/symfony (Packagist) Fixed in 7.4.18 Advisory →
  • Fix · GHSA-2v3c-qxhr-7vpv symfony/symfony (Packagist) Fixed in 8.1.6 Advisory →
  • Fix · GHSA-2v3c-qxhr-7vpv symfony/yaml (Packagist) Fixed in 5.4.54 Advisory →
  • Fix · GHSA-2v3c-qxhr-7vpv symfony/yaml (Packagist) Fixed in 6.4.45 Advisory →
  • Fix · GHSA-2v3c-qxhr-7vpv symfony/yaml (Packagist) Fixed in 7.4.18 Advisory →
  • Fix · GHSA-2v3c-qxhr-7vpv symfony/yaml (Packagist) Fixed in 8.1.6 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-16 Threatist record created from CVE-2026-109413
  2. 2026-10-27 Alias added: GHSA-2v3c-qxhr-7vpv
  3. 2026-11-06 Affected versions changed · Red Hat
  4. 2026-11-06 CVSS score added · Red Hat

References

  • TI-2019-13616 An issue was discovered in Symfony 3.4.0 through 3.4.34, 4.2.0 through 4.2.11, and 4.3.0… CVSS 3.1CRITICAL 9.8
  • TI-2018-10604 An issue was discovered in Http Foundation in Symfony 2.7.0 through 2.7.48, 2.8.0 through… CVSS 3.1MEDIUM 6.5
  • TI-2019-08131 In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and… CVSS 3.1CRITICAL 9.8
  • TI-2016-02159 Symfony before 2.8.6 and 3.x before 3.0.6 allows remote attackers to bypass… CVSS 3.0CRITICAL 9.8
  • TI-2019-08459 An issue was discovered in Symfony before 4.2.12 and 4.3.x before 4.3.8. CVSS 3.1CRITICAL 9.8
  • TI-2018-08136 An issue was discovered in the Ldap component in Symfony 2.8.x before 2.8.37, 3.3.x… CVSS 3.0CRITICAL 9.8
See all 107 →

Sources