Deserialization of untrusted data in Amazon Neptune Gremlin import
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-502.
Summary
Amazon Neptune Engine versions from 1.2.0.0 before 1.5.0.0 are affected. Deserialization of untrusted data (CWE-502) in the Gremlin graph data import component lets an authenticated remote attacker with standard database permissions execute arbitrary code and access internal service credentials.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
Deserialization of untrusted data in the Gremlin graph data import component in Amazon Neptune engine might allow an authenticated remote actor with standard database permissions to execute arbitrary code and access internal service credentials. To remediate this issue, users not enrolled in auto-update should upgrade to Amazon Neptune engine version 1.5.0.0.(Backports to 1.4.8.1 and 1.4.7.1)
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Amazon Neptune Engine users not enrolled in auto-update should upgrade to version 1.5.0.0. Fixes are also backported to 1.4.8.1 and 1.4.7.1.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA Amazon Neptune Engine (AWS) Fixed in 1.5.0.0, 1.4.7.1, 1.4.8.1
Timeline
- 2026-10-16 Threatist record created from CVE-2026-110812
- 2026-10-16 CISA SSVC decision points changed
References
Patch 3
More AWS vulnerabilities
- TI-2026-23989 crypto: algif_aead - Revert to operating out-of-place KEVCVSS 3.1HIGH 7.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-18648 Amazon AWS Amplify CLI before 12.10.1 incorrectly configures the role trust policy of IAM… CVSS 3.1CRITICAL 9.8
- TI-2024-05929 Openssh: regresshion - race condition in ssh allows rce/dos CVSS 3.1HIGH 8.1
- TI-2025-03847 Input validation issue in AWS Amplify Studio UI component properties CVSS 4.0CRITICAL 9.0
- TI-2026-11603 HTTP/2 Stream Parser Confusion Body-Inspection Bypass in Amazon CloudFront with AWS WAF CVSS 4.0HIGH 7.9
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences