phpMyFAQ e-mail change lacks password check, enabling takeover
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
phpMyFAQ before 4.1.9 and 4.2.0-alpha before 4.2.0-beta does not ask for the current password when a user changes the account e-mail address in the user control panel, so the change relies only on the session and CSRF token (CWE-308). An attacker with a hijacked session can point the e-mail at a mailbox they control and then use the password reset flow to take over accounts without two-factor authentication, including superadmin accounts.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
phpMyFAQ before 4.1.9 and 4.2.0-alpha before 4.2.0-beta does not require the current password when changing an account e-mail in the user control panel (UserController::updateData, api/user/data/update), checking only the session and CSRF token. An attacker with a hijacked session can set the e-mail to their own mailbox and use the password-reset flow to take over non-2FA accounts, including superadmin.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Fixed versions are phpMyFAQ 4.1.9 and phpMyFAQ 4.2.0-beta.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA phpMyFAQ (thorsten) Fixed in 4.1.9
- Fix · CNA phpMyFAQ (thorsten) Fixed in 4.2.0-beta
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
thorsten phpMyFAQ 4.2.0-beta
24 records Highest priority Priority HIGH 10 HIGH, 10 MEDIUM, 4 LOW
Other records, highest priority first
- TI-2026-76108 Unauthenticated denial of service in phpMyFAQ API paginationPriority HIGH 77
- TI-2026-76115 Authorization bypass in phpMyFAQ REST API edits restricted FAQsPriority HIGH 73
- TI-2026-76101 Privilege escalation in phpMyFAQ group category restrictions APIPriority HIGH 72
- Release ·
thorsten phpMyFAQ 4.1.9
14 records Highest priority Priority HIGH 5 HIGH, 6 MEDIUM, 3 LOW
Other records, highest priority first
- TI-2026-76118 Authentication bypass in phpMyFAQ via WebAuthn credential injectionPriority HIGH 81
- TI-2026-76115 Authorization bypass in phpMyFAQ REST API edits restricted FAQsPriority HIGH 73
- TI-2026-76113 Cross-site request forgery in phpMyFAQ search index administrationPriority HIGH 70
Timeline
- 2026-10-18 Threatist record created from CVE-2026-111884
- 2026-10-18 Alias added: GHSA-ch92-qpmj-fc56
References
More thorsten vulnerabilities
- TI-2023-00296 Improper Authentication in thorsten/phpmyfaq CVSS 3.1CRITICAL 9.8
- TI-2026-76118 Authentication bypass in phpMyFAQ via WebAuthn credential injection CVSS 4.0CRITICAL 9.3
- TI-2026-32868 phpMyFAQ - Unauthenticated Two-Factor Authentication Brute-Force via /admin/check Endpoint CVSS 4.0CRITICAL 9.3
- TI-2026-76108 Unauthenticated denial of service in phpMyFAQ API pagination CVSS 4.0HIGH 8.7
- TI-2026-53313 phpMyFAQ 3.1.0 through 4.1.6 Authentication Bypass via LDAP CVSS 4.0HIGH 8.8
- TI-2026-34083 phpMyFAQ - Unauthenticated Information Disclosure via getIdFromSolutionId Permission Bypass CVSS 4.0HIGH 8.7
Sources
- CVE-2026-111884 · CVE Program
- CVE-2026-111884 · NVD
- FIRST EPSS
- GHSA-ch92-qpmj-fc56 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences