ApostropheCMS publicApiProjection bypass via public REST API search and sort
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
ApostropheCMS, an open-source Node.js content management system, has an unauthenticated information exposure in its public REST API. Prior to 4.34.0, a public REST API type that uses publicApiProjection can leak excluded searchable or sortable fields through search membership and sort ordering. Returned fields stay filtered by the projection, so an attacker can make targeted inferences about hidden values rather than dumping fields (CWE-200). CISA's SSVC rates exploitation as PoC, automatable yes, technical impact partial.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
ApostropheCMS is an open-source Node.js content management system. Prior to 4.34.0, a public REST API type that uses publicApiProjection can expose excluded searchable or sortable field information through search membership and sort ordering oracles. Returned fields remain filtered by the projection, so the issue permits targeted inference about hidden values rather than an unrestricted field dump. This issue is fixed in version 4.34.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| apostrophecms | apostrophe | before 4.34.0 | 4.34.0 | Patch available | CNA |
| — | apostrophe (npm) | before 4.34.0 | 4.34.0 | Patch available | GHSA-rqgm-cfrp-4hx8 |
- apostrophe Vendorapostrophecms Affected before 4.34.0 Fixed in 4.34.0 Patch available CNA
- apostrophe (npm) Vendor— Affected before 4.34.0 Fixed in 4.34.0 Patch available GHSA-rqgm-cfrp-4hx8
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apostrophecms:apostrophecms:*:*:*:*:*:*:*:* | — | — | apostrophecms |
- cpe:2.3:a:apostrophecms:apostrophecms:*:*:*:*:*:*:*:* Versions — — ·apostrophecms
Remediation
Upgrade ApostropheCMS to version 4.34.0 or later, which fixes the issue. Affected installations on npm should move to 4.34.0.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA apostrophe (apostrophecms) Fixed in 4.34.0
- Fix · GHSA-rqgm-cfrp-4hx8 apostrophe (npm) Fixed in 4.34.0 Advisory →
Timeline
- 2026-10-20 Threatist record created from CVE-2026-112954
- 2026-10-21 Alias added: GHSA-rqgm-cfrp-4hx8
- 2026-10-21 Fix available: npm/[email protected] · GHSA-rqgm-cfrp-4hx8
- 2026-10-21 CVSS score added · GHSA-rqgm-cfrp-4hx8
- 2026-10-21 Weakness changed · GHSA-rqgm-cfrp-4hx8
- 2026-10-21 6 new references · GHSA-rqgm-cfrp-4hx8
- 2026-10-23 CISA SSVC decision points changed
- 2026-10-23 Priority changed: LOW → MEDIUM
References
Other 5
- https://github.com/apostrophecms/apostrophe/security/advisories/GHSA-rqgm-cfrp-4hx8
- https://github.com/apostrophecms/apostrophe/commit/06e4b377f3c360f9e89c32dccd7e505ad5ddf498
- https://github.com/apostrophecms/apostrophe/commit/40b989b1a9dd23d30029b8ce7668634265cfe5ea
- https://github.com/apostrophecms/apostrophe/releases/tag/[email protected]
- https://github.com/apostrophecms/apostrophe
More apostrophecms vulnerabilities
- TI-2026-25223 ApostropheCMS has Arbitrary File Write (Zip Slip / Path Traversal) in Import-Export Gzip Extraction CVSS 3.1CRITICAL 10.0
- TI-2026-32848 Apostrophe has default XSS via `xmp` raw-text passthrough in `sanitize-html` CVSS 3.1CRITICAL 9.3
- TI-2026-38664 @apostrophecms/seo Vulnerable to Stored XSS via Unsanitized Google Analytics / GTM ID Injected into Script Tag CVSS 3.1HIGH 8.7
- TI-2026-27673 ApostropheCMS: Stored XSS in SEO Fields Leads to Authenticated API Data Exposure in ApostropheCMS CVSS 3.1HIGH 8.7
- TI-2026-76992 Unauthenticated resource exhaustion via ApostropheCMS import routes CVSS 3.1HIGH 7.5
- TI-2026-76974 ApostropheCMS leaves rejected CSV uploads in temporary directory CVSS 3.1HIGH 7.5
Sources
- CVE-2026-112954 · CVE Program
- CVE-2026-112954 · NVD
- FIRST EPSS
- GHSA-rqgm-cfrp-4hx8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences